USB 2.0 docking station lagtastic


#1

I hooked the docking station up to a new Win7 Vaio laptop. I’m getting major lag, especially:

  1. With the mouse. If you move it at a steady pace, you’ll see lag-and-catchup cycles.
  2. Video. If I flip windows, there’s about a 1/2 second blur.

Any ideas before I return it?


#2

Extra note. I tried plugging the mouse directly into the computer. Still lagging, so the problem has something to do with the docking station. If I unplug it, the problems disappear.


#3

Hi - Thanks for posting first! We’re sorry you’re seeing such bad performance. This isn’t normal, so let’s figure out what’s happening.

First - the 1/2 second blur sounds like “optimize for video” maybe has been turned on (available from the DisplayLink system tray applet). We never recommend turning on that optional setting unless you’re only using the monitor to play full-screen video. Is that on, and is the blur gone as expected with it off?

Now, either way that shouldn’t affect the mouse movement significantly. So we have a bottleneck somewhere. USB graphics adapters make full use of CPU and the USB bus.

Can you say what Vaio laptop model you have (with that, we’ll look up CPU and GPU specs)? And what other USB devices are attached?

That’s enough to get started, but if you’re able to dig deeper, and are familiar with Windows 7’s built in “Windows Task Manager” and “Snipping Tool”, would you be willing to capture snapshots of the Windows Task Manager “Processes” and “Performance” tabs (try to use them on the USB monitor, so we see the picture with it in use). Snapshots should look something like this:

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0i8gfsmRsk-DO39jxg8mxYw_5W-7hUVF-OX--tFNLXMSUip5p6UotzioV9i0qNVED0yNJaPnzynRaHkmN-yrWwQ=.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/363060/windows-task-manager-performance.PNG)
!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0j8FG80C2gCvnS0MgkvT1yX55w-8gDGhNV8hGEXvA25OV9hd7HaAvHw4dcL1FyzXzC8SFmmnZHftQ0jNQm4ShEU=.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/363062/windows-task-manager-processes.PNG)

Again, our apologies, and we’ll work to get this figured out.
Bernie


#4

Thanks for the quick reply. Let’s go through point by point.

  1. Nope, optimized was off. Additionally, beyond the “shimmy”, I get real lag opening and closing windows.
  2. I’m @ about 2-6% CPU usage at rest. If I touch the mouse, it goes to about 16-20%.
  3. Vaio VPCEA. Details in pic below.
  4. On the performance screen shot, you can see (esp. on the right 3 processors) flatlines when I’m doing nothing, spiking to over 30% for just moving the mouse around.

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0ruFUJOQWV-8gk9_9U87AmvEzLtf-426h2llkNEA7fLqq5S3iM0BGmyFrneTSgfWyg==.jpg)](http://s3.amazonaws.com/satisfaction-production/s3_images/363094/Vaio_info.jpg)!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0rJ68spCzXN6-w3UMpLf_SyTYHj-RZTaA7D015Q4qBaFLa5wfnPioYjDrWC0M50a1A==.jpg)](http://s3.amazonaws.com/satisfaction-production/s3_images/363096/resources.jpg)!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0hCXFR67XHbcSpg96c89s7NzIy_zm4rD73Wr8zOGKKjtrmet8F1HV3uZV13NMWbGZQ==.jpg)](http://s3.amazonaws.com/satisfaction-production/s3_images/363098/resources2.jpg)


#5

Thanks so much for the quick reply!

Your system has plenty of CPU horsepower, so that’s 100% good – but unfortunately it does appear to have hybrid/switching Intel/nVidia graphics, which is historically a source of problems. So let’s see if we can get this solved.

The specs I’m looking at for your laptop are http://reviews.cnet.com/laptops/sony-… Let me know if that’s not the right model.

Hybrid/switching graphics are a complex system for switching GPUs behind Windows’ back, so you can run either a high-power/high-performance GPU, or a lower-power/lower-performance GPU. But in combination with USB graphics (which adds displays to Windows behind its back), it has historically been a big compatibility problem. DisplayLink has made a lot of progress in recent driver versions, though, so If you haven’t already, please upgrade to the latest DisplayLink drivers version 5.5 M1 dated Dec 3, 2010, available here: http://displaylink.com/support/downlo…

Do those drivers make a difference?

If not, next step will be to look for a way to disable the switching (stick with either Intel or nVidia GPU), and confirm if that makes a difference.

If we can’t find a way to solve this conflict, we’ll help get you that full refund (Amazon processes all refunds in first 30 days, no hassle). Unfortunately that’ll likely mean any USB graphics solution won’t work for this laptop, because they’ll all run into the same issues.

Thanks again for your patience while we see if we have a solution here,
Bernie


#6

Hi there;

  1. Wrong one. It’s the VPCEA, specifically a custom vpcea390x. Not sure what that other one is.
  2. Downloaded, though I let the unit update all the drivers when it installed. No difference.

Thanks,
Craig


#7

Hi Craig,

Sorry, I should have insisted on exact model - saw only one with Core i5.

I’m seeing options for either Intel or ATI graphics for this one. Do you know which one you have?

Thanks,
Bernie


#8

Intel


#9

Hi Craig,

Would you be willing to take a call to work through this problem? With a Core i5 and Intel graphics, you just shouldn’t be seeing this kind of performance problem.

If you’re willing, just email the best number to call you to support@plugable.com, and we’ll give you a ring.

Sorry the cause of this mystery isn’t immediately obvious.

Bernie


#10

A quick update on this problem:

We’ve worked with Craig on the phone, and the mouse and window lag appear to be solved by latest driver, however Craig is still seeing an effect that appears to be very similar to “optimized for video” being enabled (when anything changes on the screen, it appears fuzzy at first, but then snaps clear within a 1/2 second or so). The confusing thing is, the optimized for video option is not checked on his system!

So we’re going to go back to DisplayLink and figure out if there’s anyway this setting can somehow get stuck on, causing this effect. That’s in progress.

We thank Craig for his patience and for letting us know any additional clues he runs across.

Bernie


#11