USB 2.0 802.11n Wireless Adapter does not work with Windows 10


#1

I purchased the Plugable USB 2.0 802.11n Wireless Adapter for use with my new Windows video editing PC. I first loaded Windows 7 Home Premium on the PC and the 802.11n Wireless Adapter worked perfectly with my home Wi-Fi network. I’ve since upgraded the PC to Windows 10 and now the Adapter does not recognize my network’s security key. Windows 10 can see the adapter (as the Realtek RTL8188CUS chipset) and the Wi-Fi networks in the area, including my home network, but it simply won’t accept the security key.

It’s the same DSL modem and the same security key that worked fine with Windows 7 and all other Wi-Fi devices in my home. I have tried installing new drivers and the issue persists.

I have another copy of this Adapter on an old Win XP machine on the same home network and it works splendidly.

Any advice would be appreciated.

Thanks,

Bob C


#2

Hi Bob,

Can you try your other adapter from your XP machine on your Win10 machine and see if the behavior is the same?

Thanks!


#3

Since we have not heard back in 3 days I’m closing this thread. If you need additional support contact us at support@plugable.com


#4