USB 2.0 4-Port Hub not working for Raspberry Pi. It supplies power, but doesn't work for peripherals


#1

I bought a plugable USB 2.0 4-Port Hub with Battery Charging Function from Amazon on April 6, 2013 to use with a Raspberry Pi. It works fine for supplying power to the Pi, but it has never worked for any other USB peripheral devices. Initially I only used it for power because I did not have a Male-A to Male-A USB cord, but once I aquired one (and some extras from Monoprice) no USB devices I tried worked. I tried usb thumb drives, logitech wireless mice and keyboards,wired usb mice and keyboards. Nothing. Today I tried it with my home pc and and a wired mouse and it did not work. I then tried a much older power hub and it worked fine. My conclusion is that the pluggable hub is, unfortunately, defective. Any suggestions?

An additional note, all the ports on the hub work fine for powering the Pi. It just seems that anything that transmits data fails.

Thanks,
Tim


#2

Hi Tim,

Thanks for posting! We’ll be able to help.

USB hubs are not like network hubs – USB is a host/device (or master/slave) bus. USB hubs have a single upstream port to the USB host computer, and several downstream ports to devices.

So where things went south is in purchasing the A-A male cable. That type of cable is actually not allowed by the USB spec, because it doesn’t make sense (although some non-standard devices do substitute an “A” can where a “B” can should be).

So with the right cable connected to the right place, you’ll be working. What you want is the mini-B to A male cable that came with the hub. If you connect to the mini-B port on the hub (the B port is always on the device/hub side) and then to the female A port on the Pi (the A port is always on the host side), you’ll see the devices attached to the hub.

This video shows what you need to do (with another one of our hubs):
https://www.youtube.com/watch?v=pDA7Mx…

Let me know if that isn’t clear if or anything still isn’t working. Thanks!
Bernie


#3

Thank you, Bernie! I was obviously missing a key usb concept, but after carefully reading your reply I was able to correctly setup my Pi with the hub and every thing is working great. Thank you for the quick reply.


#4

Glad to have you up and running!


#5