Update to MacOS 11.4 = USBs not working

Have an M1-based MacBook Pro. Chose the docking station to get around the 1-display limit. I have a few USB-connected peripherals (HP printer, Yealink speaker/mic, and Yealink headset). Prior to updating to 11.4, all worked.

Now that I updated to 11.4, the dual external monitors still work (after I went in, turned off “screen recording”, rebooted, and turned recording back on). However, the computer does not recognize the external printer or either of the Yealink devices (unless I plug directly into the only other USB-C port I have. Seems pretty basic here, so puzzled why those devices are not recognized through the Plugable station after the update.

Anyone have any thoughts? Thanks in advance!


I have been having similar issues with a different dock UD-3900PDZ. All the USB connected devices no longer work on my M1 Mac mini on 11.4. Anyone have any remedies to this problem…I’ve seen a few posts that look to be similar issues.

I contacted their support (they’re pretty responsive) and here’s what they told me to do, which worked for me, and maybe it will help you:

  1. Disconnect all USB peripherals connected to the dock
  2. Disconnect docking station from host machine, then disconnect the power adapter from power
  3. Leave unplugged for 1 minute for power to dissipate
  4. Connect docking station initially into power only
  5. Connect docking station to host machine, then connect USB peripherals and test for functionality

Hopefully this is not a frequent problem, because doing all of this repeatedly would be a pain. But, so far, it hasn’t recurred. So, fingers crossed.

Hope this helps you out!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.