Universal Control MacOs

Hello,

Since last update universal control has completely stopped working on my MacBook Pro.

Very strange things happen that I have tried to fix with reboots of all devices, resetting SMC, PVRAM, etc. and nothing.

I have a Mac mini, iPad Pro and MacBook Pro 16 Intel (all compatible with Universal control).

The Mac mini and iPad detect fine but with the Macbook there is no way.

If I have it connected to multiple monitors via a Thunderbolt dock TBT3-UDZ it does not detect any other device for universal control (yes for adding sidecar).

If I connect universal control with iPad and the Mac mini without the Thunderbolt Dock, and I connect, universal control process death and I can’t use universal control.

Before last update, I could perfectly have the Macbook with two monitors connected by TBT3, the Mac mini and the iPad Pro all connected by universal control.
If I connect two monitor without TBT3, it work finds too.

Now there is no way and I don’t know what else to try.

Thanks

Hello Alberto,

Thank you for reaching out to Plugable Support!

I am sorry to hear that you are running into issues with your TBT3-UDZ, but I would be happy to help diagnose the issue.

From a quick Google search, it seems like this macOS update broke Universal Control for a lot of people. For example, this article here mentions it: https://origin-discussions-us.apple.com/thread/253893053

Some users mention that updating the iPad to 15.5 has solved the issue for them, but others have reported that it doesn’t help. All to say that this seems to be a known issue on Apple’s end, so I am unsure if we are able to point the issue to the dock.

Please let me know if you have any other questions!

Thank you,

Evan
Plugable Technologies
www.plugable.com/support