UGA-4KDP freezing/hanging/non-responsive when using multiple adapters


#1

I have two UGA-4KDP adapters plugged into the USB 3.0 host controller of my Lenovo Thinkpad OneLink Pro docking station (hooked up to a Thinkpad Yoga S1 running Windows 10 Creators Update) so that I may use a total of 4 monitors (2 outputs are from the Intel graphics adapter via a Startech DisplayPort MST hub). Sometimes this setup appears to work fine but other times when I dock my laptop one or both of the UGA-4KDP adapters stops working and will go black or show a frozen image on the monitor that is connected to it. If I check device manager, it shows one of two things, either “Device cannot start” with the device listed under ‘Display Adapters’ or “Unknown USB Device (Set Address Failed)” with the device listed under ‘Universal Serial Bus controllers’.

I have tried moving one or both devices over to the USB 2.0 ports but they still seem to have the same issue when both are plugged in. Oddly enough, using one UGA-4KDP at a time doesn’t seem to introduce this behavior it’s only when I have both plugged in. I have downloaded the DisplayLink driver cleaner utility and removed all drivers, loaded all available windows updates and installed the latest (8.2.2139.0) drivers from DisplayLink but still the issue persists. I have also disabled selective USB suspend and fast boot in the power profiles of windows. The issue seems most prevalent when there is a power state change (resuming from sleep once the laptop is docked, restarting, or starting from a clean shutdown).

I am beginning to think there is some sort of USB controller issue with the OneLink Pro dock but I have not found anything that points to that from the Lenovo support sites. The dock is running the latest available firmware and laptop is running the latest BIOS. I have checked for USB host controller updates but those appear to be up to date as well. I really do not believe I am hitting a bandwidth issue on the USB buses because the only other devices on the dock are a Gigabit NIC and my USB keyboard and mouse; plus I am only driving the UGA-4KDPs at 1080p resolution currently, nothing higher has been tested yet. I can provide logs generated by your PlugDebug tool upon request and would certainly appreciate it if you could offer me any suggestions or help outside of what I have tried already.

Thanks for you support!


#2

Hi Ryan,

Thank you so much for reaching out to us, I am sorry that you have been running into this issue, but I would be happy to assist!

I appreciate you various troubleshooting steps, as well as the fantastic indepth description of your setup, the configurations you have attempted, and the occasions in which everything has worked.

I am a little concerned that the issue is stemming from the docking station itself, in unison with our adapters. We normally find that our adapters do not behave the way that they should with third party docking stations. I would really like to take a look at some individual log files to see if I can pinpoint any failures, and see if we can alleviate the issue. When you have a moment, could you please keep everything connected and send us the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug as this will allow us to examine some log files from your system to help determine the next steps. Once you have downloaded and ran the PlugDebug application, could you please attach the .zip file it saves to your desktop to a direct email, and send it to support@plugable.com?

Also, is it possible to connect the two Plugable adapters directly to your system, and see if the same behavior appears? Or is that what you attempted when you attempted to attach them to USB 2.0 ports?

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Hi Marc,
Thank you for your support on this issue. I have emailed you the requested logs (Subject line of “RE: UGA-4KDP freezing/hanging/non-responsive when using multiple adapters”).

Now, when you say “We normally find that our adapters do not behave the way that they should with third party docking stations…” do you mean third party as in third party to Plugable, or third party in general? The dock is not a generic USB 3.0 Dock that so many brands sell these days, it is a first party [OEM] Lenovo dock used by many, many folks whose companies run Lenovo Thinkpad products that powers the laptop and expands the ports via a single plug interface (See: https://support.lenovo.com/us/en/solu…).

To answer your query / test scenario, I have to use my dock as it provides the DisplayPort output to my MST hub that allows me to connect 2 out of the 4 monitors used in my setup. However, while the laptop is docked to provide display output to the two DisplayPort monitors, I will unplug the two UGA-4KDP adapters from the dock itself and plug them into the USB 3.0 ports directly on the laptop to see if that makes any difference. When I said previously that I had connected the adapters to the USB 2.0 ports, that was on the dock. The laptop chassis itself has 2 x USB 3.0 but I had not plugged into those in the test you referenced.

Also possible worth noting, I observed that when one or both of the Plugable adapters freezes or drops from the system that the built-in laptop screen itself shows up in the list of monitors under Windows’ “Display Settings”. I have this disabled (i.e. “Disconnect this monitor” setting) usually when docked so it is curious it is re-enabling itself but it is a “chicken or the egg” scenario where I’m not sure if Windows just re-enables the monitor when the Plugable adapter(s) have issues, or if the Plugable adapter is causing some sort of conflict. Anyways I thought I would mention it.

I have attached an image showing how my displays are setup with the top two being the Plugable adapters and the small monitor off to the right being the disabled-when-docked laptop screen (bottom two are DisplayPort coming from the MST hub attached to the dock).

As indicated, for your test request, I currently have the Plugable adapters plugged directly into the laptop and not the dock. So far it’s been okay today. However, hopefully that is not the long-term solution for connection though as I’ve had multiple older DisplayLink chipset (DL-165) based adapters both connected via the dock without issue (it is cumbersome to plug multiple USB devices into the laptop while docked since this Thinkpad Yoga S1 only has a single USB port on either side of the laptop chassis). This problem seems to be unique to the newer DisplayLink chipet used in the UGA-4KDP when connected to my dock.

Thank you,
-Ryan

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622815/2017-07-17_11h53_25_inline.png?1500306969)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622815/2017-07-17_11h53_25.png?1500306969)


#4

Just an update:
As I was just submitting my reply, the Plugable adapters both hung/froze while connected directly to the laptop (with dock still attached for DisplayPort output). Unplugging and re-inserting them into the USB ports restores connectivity temporarily but a few minutes later, one or both Plugable units will disconnect again. On the most recent disconnect one device disappeared entirely from the system (didn’t show up in display adapters or unknown USB devices in Device Manager). Unplugging and re-inserting brought it up again. Very strange behavior.

***Further update***
Since the test scenario hooking up both Plugable adapters directly to USB 3.0 ports on my laptop did not appear to help the issue, I have moved them back to the dock USB 3.0 ports.

Some more information that may prove helpful in diagnosis of the issue:
The application I was using most on the Plugable adapter attached monitors, when they experienced the issue, was VMWare Horizon View Client. The View Client software sees all four of my monitors and upon app sign-in I would select the two Plugable-attached monitors (the ones on top in my previous post configuration screenshot). When I am signed into the View Client desktop it shows two “virtual” monitors attached which are the ones I selected so it must be utilizing the local DisplayLink drivers at least partially but abstracted in some way since Device Manager on this virtual host shows ‘VMware SVGA 3D’ as the actual adapter type (the 2 monitors are listed each as ‘Generic Non-PnP Monitor’).

All of that to say, I wondered if the View Client software could be crashing the Plugable drivers periodically when refreshing its attached hardware inventory from my local machine. I know that multi-monitor support is a newer feature for the View Client software so it wouldn’t surprise me if it had not been tested with USB adapter-connected monitors (specifically in this case, ones that feature newer DisplayLink chipsets). As a test scenario I have changed my “Main Display” in my local windows install to one of the Plugable adapters and extended my display to the additional Plugable adapter and then also my Intel Graphics Adapter (DisplayPort MST Hub) connected monitors. My laptop screen that was listed as ‘Disconnected’ in the ‘Display Settings’ windows is not showing up currently. My updated config looks like this:

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622869/2017-07-17_13h19_34_inline.png?1500312081)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622869/2017-07-17_13h19_34.png?1500312081)

I have been running this way for 20-30 minutes now without an issue. The real test I think will be putting the laptop through the workflow of ‘Sleep > Disconnect Dock > Resume on Laptop (undocked) > Sleep > Connect Dock > Resume (docked)’ to see if putting the disconnected laptop screen back in the mix of the monitors listed in “Display Settings” causes the behavior to start again or not). Fingers crossed the issue is with the way View Client software is utilizing the local display adapter drivers but we shall see…


#5

I tested the workflow I referenced in my last post (‘Sleep > Disconnect Dock > Resume on Laptop (undocked) > Sleep > Connect Dock > Resume (docked)’) and so far so good! My laptop screen *did* show up as expected now under the “Display Settings” window but it has remained in the selected ‘Disconnected’ state and appears to not be interfering with the rest of the setup at present (not re-enabling itself as I had seen when the Plugable adapters were disconnecting).

I will continue running with this setup today report back as to how things behave.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622878/2017-07-17_13h36_57_inline.png?1500313222)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1622878/2017-07-17_13h36_57.png?1500313222)


#6

Well, my theory about the VMware Horizon Client crashing the drivers hasn’t been completely disproved but, an hour so after my last post the crash did occur again (this was with the Horizon Client running on the two Intel Graphics Adapter connected monitors). This is what the failure looks like in Event Viewer:

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623716/2017-07-19_09h52_45_inline.png?1500472380)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623716/2017-07-19_09h52_45.png?1500472380)

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623717/2017-07-19_09h53_19_inline.png?1500472425)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1623717/2017-07-19_09h53_19.png?1500472425)

Since it is the UMDF drivers that are crashing I targeted that angle in my troubleshooting. A few searches turned up some known problems with the Microsoft provided USB 3.0 drivers in Windows 8.1/10. Those drivers appear to be from 2013 and Windows Update does not offer any newer at present. Microsoft’s stance is that their USB 3.0 driver is ‘good enough for most folks’ so it would appear that especially the xHCI driver hasn’t had much additional development or testing done. However, Intel has continued to develop and test their first party USB 3.0 driver and releases updates semi-regularly for Windows 7 et al. that provide better device compatibility than the comparable Microsoft drivers.

With this in mind I found a source for the latest Intel USB 3.0 drivers that are re-signed/modified to install in Windows 10 and compatible for most intents and purposes:

http://www.win-raid.com/t834f25-USB-D…

However, these drivers did not seem to solve the crash by themselves as I experienced a crash after rebooting post-installation.

Along with the updated Intel USB 3.0 drivers I noticed there was a newer BIOS update for my laptop so I downloaded and flashed that to my machine as well. While performing a post-flash inspection of the BIOS options I noticed that there was a USB 3.0 port mode option which allowed the user to select whether the SuperSpeed USB 3.0 ports were presented to the OS as only USB 3.0 ports, only USB 2.0 ports, or ‘Auto’ which was a hybrid mode allowing the OS to set the mode based on the connected device.

This BIOS option seemed like a big clue to the issue as the ThinkPad dock seemed like it was hung/disconnected when the Plugable adapters would freeze (the dock would show a re-connection pop-up from its tray icon in Windows and would resume functionality while the Plugable adapters would remain frozen until reconnected). This USB 3.0 option for the SuperSpeed ports was set at ‘Auto’ so I set it to ‘Enabled’ instead (so as to try and eliminate the possibility of the dock trying to switch modes post-connection of a device which I theorize could easily cause a UMDF device driver to stop working).

Upon rebooting into Windows, the dock behaved quite strangely with the built-in audio adapter being detected but the Gigabit Ethernet adapter showing up as a non-enumerated USB device and thus not usable. Googling around in regards to NIC issue I found reports of this behavior when the USB 3.0 BIOS option was toggled on specific BIOS revisions. So I went back into the BIOS and reset the mode to ‘Auto’ then booted back into Windows. This allowed my dock behavior to return to ‘normal’ and the NIC returned and was usable again (I noticed Windows re-installed the driver). With the NIC restored, I did a final reboot into the BIOS and turned the option again back to ‘Enabled’ for the USB 3.0 ports. This time when Windows booted the NIC remained unmolested and was usable.

At this point I also had come across some troubleshooting advice for UMDF USB device driver crashing issues which recommended enabling the option for ‘Show Hidden Devices’ in device manager and then uninstalling *all* USB Hubs for *both* the USB 2.0 and USB 3.0 types and then allowing windows to re-detect and install their driver (in this case the modded Intel drivers). I performed this un-installation, rebooted Windows, and let the OS re-detect and re-install all USB Hub devices.

The last steps with clearing the USB Hubs was completed yesterday by close of business and today I’ve been docked and working on the 4 monitors without any visible issue since then. I say ‘visible’ because upon resuming from sleep I see in Event Viewer that the UMDF crashed as pictured again but it would appear windows was immediately able to reset the UMDF services and Plugable device drivers to a working state before any image came onto the monitors as I never noticed anything freeze/flicker or drop out. Hopefully I am on track to having the issue functionally resolved.

To summarize, at this point it doesn’t look like VMWare Horizon Client is the actual culprit as I have gone back to using that software spanned across the two Plugable-connected monitors and have not yet experienced a crash while working. The root cause is looking to be related specifically to my ThinkPad Yoga S1 with this BIOS option that allows the USB 3.0 port connection mode to be altered, and/or the cleanup of ‘ghost’ devices on the USB Hub devices in the OS. I believe either the toggling of the USB 3.0 BIOS option and/or the cleanup of the USB hubs has either helped with or eliminated the issue as things have been smooth so far today.

I will post back in a day or so to confirm if things appear to be resolved but for now it looks promising. I know my posts are novels but my hope is that someone with the same hardware may be assisted if they run into this or a similar issue :slight_smile:


#7

So I still had some crashes (though not as frequent) after updating the USB 3.0 drivers, cleaning out the ‘ghost’ hubs, and toggling the USB 3.0 setting the BIOS. From the behavior preceding the crashes it seemed like the dock was actually doing a momentary disconnect/reconnect which hung the Plugable adapters on the USB bus. I was already using the dock’s 90 watt AC power adapter which should be sufficient for the two Plugable adapters but, on a hunch, I hooked both up to a powered USB hub and plugged that into one of the USB 3.0 ports on the dock. Sadly, I still had a crash so power draw didn’t seem to be the issue. Since the powered USB hub was more pricey, I returned it for a non-powered to have connected to the dock for any future devices I might need to connect (both Plugable adapters have been connected to this USB 3.0 hub, which in turn is connected to a USB 3.0 port on the dock, since then).

After doing some checking around on the Lenovo forums and support sites I came across mention of the Gigabit LAN on the dock dropping out form time to time and the recommended fix was to install updated versions of ‘Lenovo System Interface Foundation’ (current version is 1.0.78.0) and ‘Lenovo Power Management Driver’ (current version is 1.67.12.24). I installed the power management update first (rebooted), then the system interface foundation (rebooted). Between completing these Lenovo-specific updates and connecting both of the Plugable adapters via the aforementioned non-powered USB 3.0 hub, I am happy to report that I have been working without a hiccup for 2+ days!

Ironically, our company is performing a hardware refresh so I will be moving to a Surface Pro with Surface Dock and trading in the Thinkpad so all of this might have been in vain for me, lol. However, I hope the info helps someone else who might be having the crash issues when using Lenovo docks. !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1627031/2017-07-20_11h39_51_inline.png?1501104768)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1627031/2017-07-20_11h39_51.png?1501104768)


#8

Hi Everyone,

Ryan and I were able to work through most of the individual issues he was experiencing via direct email, but Ryan wanted to make sure that all of the steps he took, the information he gathered, and all of the individual fixes that he provided would be included and well referenced here on the thread.

We will be closing this thread to additional posters, but will keep all of the individual information available for future use! If you have any other questions or concerns, or would like any assistance in the steps that Ryan has taking, or clarification on any of the information display in this thread, please feel free to send us an email at support@plugable.com. We would be happy to assist in any way that we can!

If Ryan has any other questions or concerns as well, just let us know and we will get on it ASAP!

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#9