UGA-3000 Unable To Instal Driver


#1

I have download the latest driver from internet and install.
The UGA-3000 is connected on Plugable USB3.0 Hub with Charging .
When Connect the UGA-3000 , the error shown the driver is not install.
I am running on the Window 7 64 Bit .

Please Help


#2

Hi Tan,

Thanks for posting. I’d be happy to help your UGA-3000 adapter!

I’m assuming the error you are mentioning is within Device Manager and that Windows is saying a driver is not installed for the adapter (please correct me if I am wrong). Assuming I can correct, the next step is to try a clean install of the latest driver we recommend for Windows 7. Please follow these steps:

  1. Disconnect the adapter from the system and please keep it disconnected until the last step.
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features.
  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://displaylink.com/support/sla.ph…
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 7.8 M0 DisplayLink software, found here --> http://www.displaylink.com/downloads/…
  6. Reconnect the adapter to your system when prompted by the installer which will trigger the final portion of the installation

Hopefully that gets everything working properly. Please let us know the results when you have a moment and we can determine the next steps from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Hi Bob ,

Try the method above, still not able to the driver install. Windows still shall the driver is not correctly. Please advise further step.


#4

Hi Tan,

Thanks for testing and getting back. The next step is to have you send the output of our PlugDebug utility --> http://plugable.com/support/plugdebug to support@plugable.com with ‘Ticket 115452’ in the subject line. This will allow us to match everything up and examine some log files from your system to help determine the next steps.

Thank you,

Bob


#5