UGA-2k-A software Not working after Vista 64 reboot


#1

I have a Plugable UGA-2k-A and running Vista 64. If I reboot, the software shows in the tray and pops up the menu yet no matter what I click on, nothing happens.


#2

Hi Lutz,

Thanks for reporting this. We don’t want to leave you “un-monitored.” (that’s the best mood message I’ve seen!)

A few questions to try to figure it out:

How long have you had the adapter … Has this problem been a one-time thing, something that has happened on some reboots, or every reboot?

Either way, does unplugging the adapter and replugging bring it back? If not, are you connected via DVI – and if you are, does disconnecting both DVI and USB, then reconnecting USB and then DVI (in that order) bring it back?

From that, we should be able to figure out next steps for avoiding it in the future. Thanks for your patience while we figure it out!

Best wishes,
Bernie


#3

It seems to happen when Vista reboots in mode where second screen (my TV monitor) is set as main screen. I tried unplugging USB replugging - software doesn’t do a thing. Disconnecting DVI and USB and replugging in various combinations - dead to world. The only thing is to uninstall software/drivers and reinstall.


#4

Hi Lutz - Thanks, this helps.

There are two way that users thing of as setting USB display to main screen: From the Windows display control panel 1) checking the check box for “make this monitor primary” or 2) setting the USB display to mirror the laptop display.

Just to confirm, which configuration do you have which causes this problem? And if you do configure the other way, what happens?

And what DisplayLink driver version are you using right now? Is it 5.5?

Thank you! We’ll work to get this figured out.
Bernie


#5

I am currently using the 5.4 driver. I set the default monitor under windows as you suggested and it seems to have solved the problem.

I should explain that I have my TV also connected through via VGA cable. The problem is that the TV won’t allow for wide-screen resolution through the pc connection. That is why I wanted the adapter since I can connect through HDMI. The only problem is that video playback is a bit jerky so I turn off the DisplayLink and use the VGA. As long as it isn’t video, DisplayLink works well.

I’ve done all the tweaks I can think of to Vista (turn off AERO, disable unnecessary services, stop indexing, set to the lowest wide screen resolution). Any other ideas?


#6

Hi Lutz,

Great - glad it’s working with that alternative!

On performance - In all our product listings and documentation, we advise against doing video playback, 3D gaming, or similar over USB.

That said, most people will find it acceptable for youtube quality video – but not much above that. Certainly not to watch a 1-2 hour DVD where any stutters or artifacts break the viewer experience.

As far as making it a little better, there is an option to put the DisplayLink software into a lossy mode. In the DisplayLink Windows System Tray application, it’s the “Optimize for Video” checkbox. You’ll find video playback slightly less jittery with that option checked. BUT … make sure you uncheck it for normal application/desktop use to get back to lossless mode - or else fonts and everything else on the screen will seem blurry.

Beyond that, there really aren’t any tweaks to help – every pixel that changes needs to go over USB (480Mbs theoretical, ~320Mbs practical in best case). So for a video at high resolution, video playback can’t be perfect in all cases. It’s a fundamental limitation of USB 2.0, that can really only be tackled with the arrival of USB 3.0 products next year (USB 3.0 has 10x the theoretical throughput of USB 2.).

Hope this all helps. We’re always glad when customers can see the full picture (it’s part of our mission).

Thanks!
Bernie


#7