UGA-2K-A on NVidia GEForce GT 230M, Win7 64 bit -- freezing

I just bought the above device and I’m having problems using it w/ an HP laptop DV7-3085DX (i7 cpu), in that windows freeze on the monitor, or only the background outer line of any window is shown. I’m not using any fast moving programs (or games) or video, just standard IE, Firefox, email, etc… but the operation of this device seems flaky at best.

I’ve installed the latest drivers, 5.631870. My OS is Win7 64bit, the latest service packs, w/ 8gb RAM. The video card is an NVidia GEForce GT 230M, with the latest drivers installed.

The monitor is a viewsonic 24" monitor, connected to the VGA adapter, at 1920x1080, latest drivers installed.

is there a problem is usb port is connected/disconnected often? I work on my laptop and often have to take my laptop to meetings and therefore have to disconnect the USB cable…Does that constitute any problems? – thx much

Hi Cosmin,

Thanks for posting! We are sorry about the window freeze on the external monitor. Let’s try to get it to work.

First thing to try when windows freeze on Win 7 or Vista is to check whether Windows Aero is disabled (unfortunately it’s common). Can you run the Win 7 Aero troubleshooter and see if that identifies/fixes any problems and helps?…

Just let us know. We’ll figure out next steps. Thanks for your patience!

Worked with Cosmin to get this problem resolved. A disabled Windows Aero had been the cause of the issue.

If Aero is disabled on Windows Vista/Windows 7, the OS automatically disables the Desktop Window Manager which many of the latest display drivers depend on to render graphics.

Some steps that could fix most display related issues on Windows Vista/Windows 7 while using Plugable UGA-2K-A are-:

  1. Check that the latest drivers are installed. We use DisplayLink chips in all our USB graphics products. Please download the latest drivers at…

  2. Enabling Windows Aero by running the Win 7 Aero troubleshooter and see if that identifies/fixes any problems.…

  3. Disable the ‘Optimize for Video’ option on the DisplayLink Manager. For doing that click on the DisplayLink Manager(it has a blue monitor as an icon) from the System Tray. If ‘Optimize for Video’ is selected, you could de-select(by clicking on the option) it. This is especially useful to resolve the issue of flickering text on a large external monitor.

If none of the above steps fixes the issue, just shoot an email to We are always happy to help! :slight_smile: