UGA-2K-A not working with Macbook Pro 2011 model


#1

I have a new 13" Macbook Pro 2011 model running 10.6.7 with an 2.3 ghz Intel Core i5, and I am unable to get the UGA-2K-A to work. I tried installing the 1.5 driver however it says it doesn’t support the cpu. I was able to install the beta driver however nothing is happening. The light on the device is on, however the OS is not recognizing a second monitor in the display preferences. I am connecting to a Samsung 226BW monitor by DVI.


#2

Hi - Thanks for posting! That model should have no particular issues, so we’ll be able to get things going.

DisplayLink just released a new beta version (1.6 b4) – is that the version you’re now running? Have you had a chance to reboot and unplug/replug since the install of the older 1.5 version.

And can you confirm the Mac OS X version you’re on?

Thanks for your patience!
Bernie


#3

Thank you for your quick reply! I did try to install the 1.5 driver however it wouldn’t let me install saying it didn’t support the cpu. So I installed the 1.6 b4 driver. I rebooted after the installation, and have tried rebooting again, and unplugging/replugging both the USB connection and the DVI connection. I am running Snow Leopard 10.6.7.


#4

DisplayLink’s 1.6 beta 4 driver was just released, so it’s worth going to the 1.6 beta 3 driver to check if this might be a version issue.

Would you be willing to install the beta 3 version (available here: http://plugable.com/public/drivers/Di…)

And let us know how that goes?

Thanks!
Bernie


#5

I’ll give it a shot and let you know. Thank you!


#6

I tried the 1.6 beta 3, and the 1.6 beta 2 and it didn’t work with either. I was able to get the device working with a Mac Mini with a 1.83 ghz Core 2, and it worked great. It appears this is probably a driver issue; maybe it’s having an issue because of the new Sandy Bridge processors in the new Macbook Pros. I found a thread in the DisplayLink forums about issues with a new Macbook Pro with an i7 processor: http://www.displaylink.org/forum/show…. Anyways, I ran the DisplayLink diagnostic tool. Here is the output from that: http://dl.dropbox.com/u/23433742/Disp….

If you look in the system.log you can see it is having issues with the device/driver.


#7

Forgot to mention, the Mac Mini I got it to work on was running the same OS version: 10.6.7.


#8

Thanks for all the great info here! We’ll dig into this to figure out what might have changed with the Sandy Bridge processor generation machines, make sure DisplayLink knows what’s going on, and get back to you with a solution.

DisplayLink will be having more frequent Mac driver updates than they’ve had in the past, so if there is an issue here, I’m hopeful we’ll be able to get a driver update to resolve it.

Driver updates (if that turns out to be required) take time, though, so if any timeframes become too long, please just email support@plugable.com and we’ll take care of you.

Thanks for your patience!
Bernie


#9

nutso12, Apr-21 09:26 (PDT):

I actually tried one more time to get this to work after reading the Displaylink forums. I repaired permissions using the Apple disk utility and then reinstalled the 1.6b4 driver and it worked. I had previously tried this before and it didn’t work. Probably the driver is still flakey and hopefully when they come out with the final release this extra step won’t be needed.


#10

Just for the benefit of others, a permissions problem appears to sometimes arise on Mac OS X, which then causes a driver load problem. So the symptoms are that drivers appear to install fine, but the adapter does nothing (in the DisplayLink logs there will be an error where the DIsplayLink software can’t find the kernel-level driver).

The solution is to: uninstall your current DisplayLink drivers, repair disk permissions, and then reinstall the latest DisplayLink drivers (from http://displaylink.com/support/mac_do…)

You can repair disk permissions by

  1. Open the Disk Utility application (in Applications->Utilities)

  2. Select the main disk volume in use (that OS X is running from), in the left pane

3… Press the “Repair disk permissions” button on the right tabbed pane (the “first aid” tab must be selected)

Thanks for the patience here - and hope that helps anyone else hitting the issue!

Bernie


#11

I’m having this issue also - i have a MacBook PRO 13" with intel core i5, 2.3 GHz, 4 GB RAM and running snow leopard, 10.6.7. I am also running VMWare fusion (not sure if that is a problem)

I have downloaded the latest driver from DisplayLink and have ran the repair disk permissions. Nothing - it just doesn’t run.

Its not the adapter, i had a friend try it on his MBP 15" and it worked no problem.

Any help would be greatly appreciated!


#12

hello???


#13

Hi Daragh,

Sorry! Missed your earlier reply on this thread. The existing known instances of this Mac-specific problem are fixed by repairing disk permissions on the main drive (the drive Mac OS and drivers are installed on), so we’d like to understand what might be different about your setup.

Can you email your Amazon order # and a link to this thread to support@plugable.com? We’ll work to figure out what might be going wrong.

Thanks so much for your patience, and again my apologies!
Bernie


#14