UGA-2K-A Multi-Display Adapter Compatibility Problem and Question.


#1

I have plugged in the UGA-2K-A device, drivers for Windows 7 installed, attached the DVI-VGA attachment, and connected it to my monitor via VGA cable. Screen is black. Tried to “Detect” the monitor in the Screen Resolution section of Control Panel. I receive the message: “Another display not detected”. I have tried the connect anyway options on the Multiple displays drop down menu. No luck.

I have checked the device manager and see the the device is “working properly”. The light on the device is not lit, and I have not gotten better results after rebooting the computer 5 or 6 times. I have also removed the USB and reinserted it several times.

It is worth noting that when I initially installed the device a couple of days ago, it seemed to work. But, when I tried to reboot my computer, I was unable to reboot. I needed to reboot because my computer had become extremely slow; perhaps because of an insufficient graphics card (Mobile Intel 4 Series Express Chipset Family). I had to press F8 and reboot based on the last known bootable state. Drivers from another device may have caused this. I’m not sure. But, the UGA-2K-A drivers were reinstalled automatically after reboot and the problem of a black screen as described above began. I then tried to overwrite the installed drivers with those on the Installation CD. Presently the driver version is up to date (vesion 5.5.29055.0). Still no luck. Please help me to figure this out or let me know how to return it. I recently purchased from Amazon.com. I wonder if I may need a Matrox dualhead2go or something similar.


#2

Hi!

Thanks for posting and sorry to hear the UGA-2K-A is giving you trouble!

If the light on the device is not lit, it can mean two things:
a) Hardware problem - Unfortunately you hit a bad unit :frowning:
b) Drivers are not installed correctly

Unfortunately the drivers on Windows update are not the latest available - Before we try anything else we suggest to try downloading the latest driver from the DisplayLink website which is currently version 5.6 M1 (Which is the second update of the 5.6 series).

Click here to download the 5.6 M1 driver.

Please try the 5.6 M1 driver, and if problems persist, shoot us an e-mail at support@plugable.com with your Amazon order ID and valid address and we’ll send out a replacement to you as soon as possible.

Regards,
Lampros


#3

Thank you for the response. I downloaded the new driver, and the adapter began to work; however, everything is now running very slow. There is a terrible lag with each letter I am now writing. My computer seems to be having a tough time. I am using a Thinkpad with an Intel Core 2 DUo CPU T6570 @ 2.10GHz. 3GB RAM. Windows 7. Mobile Intel 4 Series Express Chipset Family for graphics. Graphics card cannot be replaced. I called Lenovo and IBM about this today. I would have to purchase a “System board assembly, PM45 nVidia N10M-GE1 256 MB, DDR2” for $500 + shipping.

It seems I will need to return the adapter for a refund. I’m really very upset about the fact that no information is provided about the graphics card requirements. It would seem that my system is well above the system requirements printed on the box and provided through Amazon. I even purchased a new monitor. This is so upsetting.

Do you know if there is anything better that I can purchase that provides a graphics chip in the external adapter? I think the Matrox Dualhead2go is this kind of device, but it’s hard to tell. I don’t believe much at this point. Please help.


#4

Hi,

The very minimum requirements DisplayLink recommends can be found here. Your Intel Core 2 Duo @ 2.1GHz is more than enough for DisplayLink. Even for their recommended DVD playback requirements.

The performance lag you are experiencing is abnormal. Can you please have a look at the Task Manager and see what processes you can see there?

To do this, hold Ctrl+Alt+Del. On the screen the appears click on ‘Start Task Manager’. Once there, click on “Processes”.

You should see something like the following screenshot:
!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0ro-JtLXimg95pi9OK7pWEokVjwCV-1dqnqU0WmVeTwhiK0OTGSiSfXJvd1iHoPcdw==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/507560/processes2.png)

Can you tell us what are the top 3-4 processes there and what percentage of your CPU they consume? (Or can you post a screenshot here)

Also, what is the screen resolution of the monitor attached to DisplayLink ?

As soon as we have this information we’ll be able to suggest next steps!

Regards,
Lampros


#5

Here is the image from my Task Manager:
!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0gt8tlfM9oLn6LFLBx2yC8eZ-OxL8ohENYxUhu3ErTsqTI1Flmk3CVyjm7cQPNH_zA==.JPG)](http://s3.amazonaws.com/satisfaction-production/s3_images/507906/Capture.JPG)

Screen resolution is 1280x1024 on both the DisplayLink monitor and the one connected directly to the VGA out port. Display is 1280x800 on the Thinkpad. The DisplayLink monitor is not currently connected; however, everything is still running very slow. After I connect the DisplayLink device up to the monitor, it seems the only think that gets my computer to work normally again is a reboot. I have not yet rebooted.

If you see something strange, let me know. I mailed the device back for a refund after testing the device with the new driver as you initially suggested. I actually had to unwrap my own packaging it in order to do so. Because it caused problems and you don’t have a telephone number for me to talk with someone about this, I was frustrated and believed my time was being wasted.

If there is a clear indication of what is wrong, and it can be resolved in your opinion, perhaps I will need to repurchase the device. It doesn’t appear that way to me at this point. I continue to suspect that your product requires a very top of the line graphics card, which can only be replaced along with a whole new system board assembly at great expense.

I look forward to your comments. Thank you.


#6

Sorry that you returned the device and for the trouble.

From the screenshot above, we can clearly see that the processor is not to blame for the lag you’ve been seeing.

The graphics card is also not to blame, as most of the load of the UGA would be on the processor.

For the lag you have been experiencing we suspect the culprit to be a USB port not working at it’s USB 2.0 speed (480Mbps) but instead performing as USB 1.1 (12 Mbps).

Regarding the Matrox solution: It uses the strategy of telling Windows that there is a single very large monitor, and then splitting that output across all the monitors. So if the GPU or the OS can’t handle that width, it won’t work. In contrast each DisplayLink USB device shows up as its own independent graphics output to Windows which is able to have a mode and monitor position that’s completely separate from all the others.

Regards,
Lampros


#7

Thanks for your response. I am using a hub. It is supposed to work at 2.0 speed, and I have had no problems with it until I plugged in the device. For what it’s worth, I had also experienced these issues when I plugged the device into one of my laptop’s own USB ports. Other items were plugged into the hub when this change was made.

All of this aside, I have determined that there is a major problem with the driver you had me download. As mentioned before, I intalled the driver and the device was then recognized. When I rebooted my computer over the weekend, I got a flash of a blue screen as the computer was rebooting. This caused the computer to stop and reboot, over and over until I pressed F8 and chose to have the computer boot up in its last known good state.

The only change made to my computer since an earlier successful reboot was the installation of your latest driver. If the driver is incompatible with my system or OS (Windows 7 Ultimate), perhaps this also explains the performance issues.

I would certainly appreciate your comments. I have a brand new monitor serving as a paperweight on my desk, trying to think of ways to get it working. If your drivers are bad, and the Matrox device won’t work, maybe there is some kind of video card I can purchase to slide into what I believe is a PCI slot(?).

Thank you,

Rob


#8

Rob,

Unfortunately with laptops the options for adding extra monitors are quite limited. The options are pretty much an USB Graphics Adapter such as ours, the Matrox solution, or docking stations provided by the laptop manufacturer.

Should you decide to try one of our products again we’d be happy to work with you to further troubleshoot the performance issues you’ve seen.

Regards,
Lampros


#9

It seems that the options for laptops are indeed very limited, due to the fact that their graphics capabilities are generally much lower than desktops. I find it very disappointing that the minimum requirements information that your company provides relates to the microprocessor, RAM, and the operating system. Minimum graphics requirements are not stated.

Your literature even goes so far as to say that up to 6 devices can be supported. Maybe for someone with a super strong graphics card which, in all fairness, needs to be disclosed.

The solution appears to be a ViDock, made by Village Tronic. This device enables the attachment of an external enclosure housing a separately purchased desktop graphics card. It connects to a laptop with a PCI Express Card.

I am very disappointed with your product, but even more frustrated and disappointed with the company’s apparent decision to withhold minimum graphics requirements. I feel that I have been misled.


#10

Hi Rob,

Thanks for your feedback. For all the reasons you describe, we try to be proactive about warning potential customers about minimum requirements, because it does no good to have a customer be disappointed later. We want that customer to *not* buy the product. I’m sorry we failed in that here.

Comparing Plugable’s product listings to other DisplayLink devices, you’ll often notice we have higher or more detailed requirements, because we’re trying to do that.

The reason why we don’t list a specific benchmark or list of GPUs, is because the GPU is not typically a bottleneck for USB graphics. It can make a difference, but not large enough to explain the magnitude of slowness you described on your system. Basically if it’s recent enough to have WDDM driver support, it’s enough to shift the bottleneck largely from the GPU to the CPU and USB’s throughput limit.

In particular, we’ve run and we have many customers running on similar class systems with Mobile Intel 4 Series Express Chipset Family, and the behavior you described is not normal or acceptable.

So I think there is another factor involved here. Before the adapter was returned, the process explorer seemed to point away from a CPU hog, but some CPU activity can be hidden from process explorer. The fact that the adapter behaved the same both connected to a hub or directly to the laptop points away from USB, but slowness of the class you describe almost sounds like a USB 2.0 device being stepped down to 1.1 mode. And the driver problems you experienced before upgrading could also be a clue in a different direction.

I wish there were a clear cause, but unfortunately based on the data points so far, we weren’t there yet.

I know none of this does you any good - it doesn’t solve your problem. Although I’ve never seen it running, the ViBook solution where you have a full 2D/3D accelerator via ExpressCard sounds like a good solution, focused on your primary concerns.

Again, my apologies,
Bernie


#11

Thanks. Perhaps we could have gotten it to work better. That’s too bad. But, the driver issues are quite disconcerting. Maybe there is a conflict with some other software. Hard to say. I sure don’t like seeing blue screens. It scared me enough that I went and bought the Acronis back-up software and an external hard drive to keep my computer protected from the risks associated with trying new devices.

Honestly, the ViDock looks pretty risky as well. I found a YouTube video of a guy who uses it and claims he needs to switch between the external and onboard graphics card, requiring a reboot and some other steps each time the switch is made. Sounds sketchy.

In any case, thanks to you both for addressing my concerns.

-Rob


#12