UGA-2K-A Kills Video on All Adapters


#1

Windows Media Player stops working in all windows after I install the USB Displaylink adapter. I’m running Windows 7 Home Premium. The 3rd monitor works, but I can’t play video anywhere, including Media Center. How do I fix this?


#2

Thanks for the question and sorry you’re having this problem.

Can you say what DisplayLink driver version you are on?

DisplayLink has made improvements in video playback in each recent version. The first recommendation is to install the latest DisplayLink drivers (currently version 5.5, dated Sept 29, 2010 from http://displaylink.com/support/downlo… ). Are you already on that version, or does upgrading to it help?

If not, the problem is most likely protected content.

Some players are more strict than others. The strictest will not play back even in the presence of an untrusted output anywhere on the system.

We can confirm whether it’s content protection, by playing an unprotected video (like c:\Users\Public\Videos\Sample Videos\Wildlife.wmv that Windows provides as a sample). Does this play back correctly?

And can you confirm which Windows Media Player version you’re using? Is it 11?

And if you have access to another media player or older version - does it play back correctly?

Thanks - we’ll try to figure out what’s going on here.
Bernie


#3

When I first plugged in my UGA, it engaged Windows Update to download a driver automatically. During the install process there were at least 2 “Fatal” errors, but the 3rd monitor came up. After that several programs weren’t working properly so I rebooted. Upon reboot, Windows 7 would get stuck on the “Welcome” screen after login and never fully boot. I rebooted to Safe Mode, Recovered to before the DisplayLink driver install, unplugged the UGA, and the computer booted OK.

At this point, I downloaded the 5.5 driver directly from DisplayLink, installed it, plugged in the UGA, and the 3rd monitor came up. I wanted to try video performance, so I opened up Windows Media Center and it started up black - not even the intro menus. Then I tried Windows Media Player 11 for both recorded TV, purchased programs, and the wildlife video and none of those would work - the wildlife program would play sound, but only presented a squeezed still in the middle of the screen. This was the same on all 3 displays.

At this point, I used System Recovery to roll back again to before I installed anything for the UGA and now I can play video again. This failed for several attempts before finally working.

This is our primary TV viewing computer, so I can’t accept a previous version of WMP - I have to use Windows Media Center, which is based around WMP11. Do you have any other suggestions? I’m at the point I’m thinking of returning the UGA, but I thought I’d see if this was a common problem with an easy solution first.

Thanks!

-Carter


#4

Hi Carter,

It’s not a common problem with an easy solution, unfortunately. Sorry!

One thing that may have gotten the unprotected content running again, is turning off the “Turn on DirectX Video Acceleration for WMV files” option on the “Performance” tab of Windows Media Player 11. But since this is a Media Center/TV scenario, I don’t know if that would have been acceptable.

Given that you’d already tried a clean 5.5 install, there are really no other major things we can try for an immediate solution, unfortunately. All we’d do is gather debug logs to help provide info to DisplayLink for future fixes.

For our benefit in noting what system had this problem - can you say what system make/model you have? (nVidia or ATI graphics, right?).

A return is no problem - Amazon will process it quickly. We understand.

We want the return process through Amazon to be as quick and easy in the first 30 days as possible. Just visit http://www.amazon.com/gp/css/returns/… And if Amazon ever gives any trouble (after 30 days in the first year), just email support@plugable.com and we’ll not leave any customer with a system that’s not working properly - we’ll either get you fixed up, or get you a refund.

We’re very sorry the product hit these problems on this configuration! You’ve been great in working through it - thanks for your patience! And again, we’re sorry!

Bernie


#5

I was able to fix the problem.

The biggest problem was that I had too new of nVidia drivers. I thought I had a different chipset than I actually did. While the new drivers worked fine, they enabled some nasty features like not being able to split a VGA output - thanks DRM! And they must have enabled somethings that interrupted video playback when the UGA was added.

I uninstalled all the nVidia drivers and came back with the last Vista drivers they made that just supported my chip (8800 ST). That allowed me to split monitors again, so then I tried out the UGA again and everything works great.

The video on the UGA looks pretty good, so I’m pleased with that. Thanks for the quick replies. Windows troubleshooting is a thankless task when there are so many things that can go wrong that have nothing to do with your product. Hopefully this information can help people with similar problems.


#6

Hi Carter - Great job!

For the benefit of others, can you say which nVidia driver version you have installed now which is working well? And I know the drivers that were failing are uninstalled now – but any idea what version was causing the problem?

Again, thanks so much for sticking with it - and especially for posting this solution!

Thank you!
Bernie


#7

DisplayLink drivers 5.5 M1 (Dec 3, 2010) and later have a fix for this issue. Please download and install the latest driver from http://displaylink.com/support/downlo…

Thanks for the patience of the Plugable users affected by this issue who had to wait on the earlier nVidia driver version, until this fix!


#8

Just a quick note for others’ looking at this thread - it is Nvidia Driver 258.96 and earlier that is fine. Later versions of the nVidia driver introduce video playback and 3D gaming issues with all DisplayLink driver versions up to 5.5 at least.

So the recommendation at this time for nVidia users is to remain (or go back to) driver version 258.96 or earlier.


#9