UGA-165: Programs on secondary monitor reduced in size and windows frame smaller than actual screen size


#1

I just received the UGA-165 and got everything up and running. I am using windows XP and have USB 2.0 and my primary video card is a Radeon 9200 LE series. My primary monitor is a Lenovo L215WA (wide screen) and my secondary monitor is a AOC 2216Sw. I use the secondary monitor as an extension. Everything is working, but the viewable window on the display on the secondary monitor on the Plugable is reduced when at the monitor’s proper DPI setting. The only way to get rid of the “frame” outside the window is to change the DPI setting to an undesired setting, which results in poorer viewing performance, distortion, etc. I have tried switching the monitors, and substituted a third monitor, an LG W2043SE. No matter how I arrange the configuration of the three monitors, the results is always the same -they work perfectly when they are the main monitor, but when used as a secondary monitor on the Plugable adapter, the windows from size is reduced and the programs appear smaller. When maximizing a window of a program, it will cover the full real estate of the screen of the secondary monitory, but the text size and graphics are much smaller than what appears as normal on the primary monitor. And a program is closed, or the window of a program is minimized, the main windows frame is considerably smaller than the real estate of the actual screen (there is a large blue border around the rectangular frame).

I can make adequate use of the situation as it is, but would like for the program I’m viewing on the secondary monitor to be the same size as the primary monitor and not be shrunk. Hope all this makes sense and there is a simple solution.

Steve R.


#2

Bernie:

Thanks for the detailed response.

Regarding your suggestions:My desktop properties were originally set to “stretch.” Since your post, I have experimented, and setting it to to “tile” does indeed cover the entire screen now on the secondary monitor with tiles. I went back to “stretch” since this is the view I’m most accustomed to. The operating system window being reduced from the viewing edge considerably with an enclosed frame is not really a big issue, since the screen space is generally covered with programs in use anyway. But, I figured pointing out to you what is happening (and it is in “stretch” mode), might help you in determining what issues I may be having that might possibly relate to this.

  1. I had played around with the DPI default previously, and have had it at 96. I had hoped that this setting could work independently with each monitor, but I quickly learned that when trying to increasing the DPI to 120 for the secondary monitor, the primary monitor increased as well, which I didn’t like, so went back to 96.

Regarding the resolution for the AOC monitor, I tried all the lower resolution settings, and none of them were satisfactory (usually distorted) -the 1680 x1050 setting works best. You mentioned the 1280x800 setting, but that option doesn’t appear on my menu. My options on the plugable menu with the AOC connected are:

640x480
720x400
800x600
832x624
1024x768
1280x960
1280x1024
1440x900
1680x1050

BTW, my options for the LG W2043SE monitor (native res.= 1600x900) as a secondary monitor on the Plugable menu are:

640x480
720x400
800x600
832x624
1024x768
1152x864
1152x870
1280x960
1280x1024
1600x900

Again, my best option is 1600x900, but with this setting the content is subsequently too small.

I just checked out the settings for the main monitor, the Lenovo L215Wa, and it has a native resolution of 1920x1080, but I have my settings (as a main monitor, with the windows settings in the control panel) at 1280x768, which keeps the content in proportion, but larger than the tiny content viewed at the native resolution. Perhaps this is the issue we are having: the resolution settings provided by the plugable adaptor don’t match what would be my best viewed settings for these monitors, and I’m having to stick to the native resolution, which is essentially reducing the content?

And, the same issue arises when I turn the Lenovo monitor into the secondary monitor on the Plugable adaptor. I am forced to view it at the native resolution of 1920x1080, because the 1280x768 settings that work best with this monitor are not available with the Plugable adaptor -the following are available when the Lenovo is connected to it:

640x480
800x600
832x624
1024x768
1152x864
1280x1024
1400x900
1680x1050
1920x1080

None of the other settings (other than 1920x1080) are adequate.

Hopefully this additional information will provide more insight to the challenges I’m experiencing.

-Steve


#3

Hi Steve,

Thanks for the great detail here. Yes, the modes you’re offered by default are basically only a few modes Windows always offers + the native mode of the monitor + 4 alternative modes supplied by the monitor.

Unfortunately, the monitors here appear to not be offering the smallest modes that match best with their aspect ratio … frustrating.

One thing to try … let’s try to get beyond the default modes offered. Can you go to:

Display Properties > Settings > Advanced > Adapter

And look for a checkbox or a button called “List All Modes” or similar? If the preferred mode shows up, select it and click “Apply”.

Do you get any extra modes offered - and the ones you’re looking for - via these advanced settings?

Thanks for working through this!
Bernie


#4

Bernie,

I gave your suggestion a try, and there were no other modes listed in the advanced settings under “Adapter”).

In the meantime, I made one other “discovery.” When I set my main monitor (in this case the Lenovo 215Wa) in its native resolution, then my secondary monitor on the plugable adapter displayed the full windows background -not reduced with a frame as before. Viewing in the native resolution is not my preference, as the contents are smaller than what I like, but at least the secondary monitor, which is also set in its native resolution, displays the content the same size as the primary monitor.

So now, I have the choice of viewing both monitors in their native resolution, with the content reduced from what I prefer (and am accustomed to) OR viewing my main monitor in a preferred resolution, with my secondary monitor remaining in the native resolution, which is not my preference, as the size of the content is smaller than the main monitor.

I bumped the DPI up to 120 to enlarge things a bit, and that helped the situation on the monitors some.

Any further suggestions?

Thanks,

Steve


#5

Hi Steve,

Thanks for posting these details!

I’m sorry, it sounds you’re doing the most you can from a software/config perspective to work around the different sizes and resolutions of your monitors, yet shoot for UI elements that look similar.

The next step would probably be a hardware one – by selecting monitors with the same native resolution, you’ll get much closer to what you’re looking for.

And when selecting monitors, I try avoid monitors that go for maximum resolution (so they sound better on paper). Like you, I find the DPI needlessly high (and the screen elements then too small) if the resolution is high on a small panel. Unfortunately, monitor makers compete on max native resolution, so they always push that up. But if you can find larger (physical) monitors with smaller or more normal resolutions, I find them better, and they’re especially better with USB (where larger screens push USB’s inherent bandwidth limits).

Barring the new hardware, you could also compromise on setting the lower modes your monitors are offering, even if they have a bit of distortion from not being at the exact same aspect ratio.

The only other suggestion is to look within each application for ways to zoom. For example, nearly every browser lets you easily scale up/down the pages you’re viewing. But since this is per-application, it’s a bit of a pain.

Thanks for your patience in exploring the possibilities here! Please let us know if there’s anything else we can do - but again I think you’re now adjusting all the knobs that are available.

Thank you!
Bernie


#6

Hi Steve,

Thanks for posting this question! And thanks for providing good background.

Windows XP’s DPI setting doesn’t actually adjust DPI in any low-level way, rather it adjusts the size of fonts and window elements up or down, and calls it DPI to conceptually present it to the user. That method of configuration was changed/removed in Windows 7.

I’m not 100% sure about all aspects in this configuration, because the Radeon 9200 LE series is an ATI card from quite a while ago (that family launched in 2001), predating the Vista and Windows 7 eras. That wouldn’t be a problem on XP, but also it appears that ATI has some special behaviors around the DPI setting on Windows XP that I can’t test.

But I think we have a better way that avoids those issues, regardless. Here’s what I’d recommend:

  1. The behaviors where a maximized window appears to take up more of the monitor than the desktop, are usually because the desktop background is set to “center” and does not take up the whole screen. To verify, change your desktop properties to “tile” or “stretch” your desktop background:

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0ncTOjNzDO5QUFANFeDWROwB-iGk4lWp3GtPpHB9UtIH8ugSivbAfcB_AMCjbDWsRHAfquEmEP0oIdyE4Ms6hdAi3VIdN4HJ9ncv9qysl1lP.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/355018/windows-xp-display-properties-desktop-tile.PNG)

Now, is the behavior you described – “When maximizing a window of a program, it will cover the full real estate of the screen of the secondary monitor, but [if] the window of a program is minimized, the main windows frame is considerably smaller than the real estate of the actual screen (there is a large blue border around the rectangular frame).” now more what you expected?

  1. The problem with fonts and windows being too small is because the DisplayLink graphics adapter is setting a very high mode (for Windows XP) – the AOC monitor’s native mode of 1680x1050.

Rather than using the DPI setting to adjust the size of window elements (which keeps the all the pixels, but reduces resolution of window and font elements), the best way to make the sizes of everything more comfortable would actually be to reduce the pixel resolution until you like the size. Both because this avoids any strangeness of the DPI setting, but also because you have a much older machine there (AGP graphics), so you’re going to get better performance and a better experience at a lower resolution.

So you’d set the DPI back to the default of 96:

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0qr7y0beIoeB4oeklt3h4ekgJqsVMF_w1jdB6Gneia_75nPs1pZ-TwLmwrxNpVZTCQ==.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/355008/windows-xp-96dpi.PNG)

And then set your resolution lower - an equivalent lower-res mode with the same ratio and no distortion on that 1680x1050 monitor would be 1280x800.

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0l05qk9RBKx4vAtxAAKsRg4tf5bs1jSjFTtuBct9kWf9TdBAzauSZ-szU0I49YKFxxGTlQYn5r8ykqJC85WeaqcvoSNsVOv6zkT5hamjDpDw.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/355004/windows-xp-display-properties-settings-1280x800.PNG)

You should find all the window and font sizes now much larger (even at the standard “DPI”), plus have some benefits of better performance at that lower mode.

Again, I’m making some leaps here, but hopefully this goes directly at the problem you’re trying to solve and helps. Please let us know how it goes and whether any follow-up questions could help.

Thanks for your purchase and your patience while getting this configured!
Bernie


#7