UGA-125 Display Adapter Won't Work (Installation Issue?)


#1

I purchased four UGA-125 devices to try out in my department, and three of them installed with no issue via plug-and-play. Drivers were installed automatically by Windows, no system restart was needed, and the additional display functioned immediately. I have been unable to get the fourth device to function on a certain computer - an IBM Lenovo T60 (the other three devices are on two Lenovo R500 and a Compaq 6720t).

Here is what I have tried on the computer that I cannot get the UGA-125 to work on:
Automatic driver installation by Windows, driver installation from supplied CD, and installation of drivers downloaded from displaylink.com. All three methods end in the same result - Driver installation completes, and then a message pops up stating that a systems settings change took place, and a restart is needed for changes to take effect. If the computer is restarted, upon logging in the user is presented with the same restart message. If the computer is restarted again, the same message pops up after log in - the request to restart just loops forever.

Other things to note:
-The UGA-125 shows up in the Device Manager after the drivers are installed, and the drivers for the device show up in Add/Remove Programs in the Control Panel.
-If after one of the restarts mentioned above, I try to install drivers again, I get a message saying that drivers are already installed.
-I have verified that the device itself is not the issue. I tried a fresh install on the t60 with one of the devices I know to be working on another computer, and it still would not work.
-I installed the most up to date video card drivers on the t60 that were available at support.lenovo.com (ATI Mobility Radeon x1400)

I have files generated using the DisplayLink debug tool, I can send them to you if you’d like.

Thank you,
Ian


#2

Hi Ian,

I’m just checking to see if you’ve been able to get your issue resolved. If not, please do forward your DisplayLink Support tool log files over to use at support@plugable.com.

Thanks,
Jerome.


#3

Hi Ian-

Thanks for providing those logs! I noticed a couple of things right away that we can look into, so I’m hopeful this will be a pretty easy fix.

1st: I notice that you have some unusual entries in the logs where it lists the installed graphics driver. Normally we would see one entry here, however instead this is what we see:
Graphics: ATI Mobility Radeon X1400 (ATI Technologies Inc.)
Graphics Driver: 6.14.10.6925 Dated 2009/09/29
Graphics: ()
Graphics Driver: Dated 0
Graphics: ()
Graphics Driver: Dated 0
Graphics: ()
Graphics Driver: Dated 0
Graphics: ()
Graphics Driver: Dated 0

Seeing those additional “Dated 0” entries makes me suspect something is wrong here. Other possibilities exist but I recommend starting here. I’d try a full/thorough uninstall from device manager, reboot, reinstall of the same/latest graphics driver from Lenovo. Please let me know if more detailed instructions on this step would be helpful.

2nd: I notice you’re using the latest 7.0 driver from Display link- we are still currently recommending 5.6, especially for XP users.

I would recommend uninstalling 7.0 by following the instructions here: http://www.displaylink.com/support/ticket.php?id=297

Then installing the 5.6 version on this page instead:
http://plugable.com/drivers/displaylink/usb-2-0

Please let me know if either of those are helpful or if you have any further questions.

Best wishes-

Jeff Everett
MCITP Enterprise Support Tech
Plugable Technologies


#4

Hello,

I’ve gone through the following steps, at your direction:

-I uninstalled all display drivers, and uninstalled all those additional devices from the device manager.
-I uninstalled the previous installation of the display link drivers
-I then rebooted, and installed the latest drivers from Lenovo for the graphics processor. (A reboot was required after this)
-I downloaded and installed the 5.6 drivers from the link you provided

After doing all this, the result is the same - an endless request to reboot due to a systems settings change comes up.

On to Plan B?

Thanks,
Ian


#5

Hi Ian-

Sorry to hear those steps weren’t more helpful, however thanks for confirming your findings. I’m beginning to suspect a faulty device but still have a couple other possibilities I’d like to look into before jumping to any conclusion.

I’d like to see if anything looks different in the logs at this stage, would it be possible to get a new copy of the output from the DisplayLink Support tool? If you send those to support@plugable.com attention Jeff (or reply to the previous email thread where you sent the first ones) that would be very helpful.

Thanks for your patience as we work through this.

Best-

Jeff


#6