Ud6950z

Hi, when I connect the HDMI cables from my monitors to the Plugable Docking station HDMI ports my monitors do not work.

Hi Jeff,

Thanks for reaching out to Plugable support! I’d be happy to help with that docking station.

The first steps we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.

  2. Uninstall any and all software with ’ DisplayLink ’ in the title that is present from within the Control Panel -> Programs and Features . Don’t worry if these entries are not present or if the process does not work, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.4 M0 DisplayLink software (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+9.4+M0.exe)

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Thank you for giving us a chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

Hi. I tried what you said but the monitors still don’t work.

Hi Jeff, is this a new dock or has this worked in the past?

This is a new dock.

Hi Jeff,

Thank you the information you provided and the testing you have performed that is much appreciated. Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 327048’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Hi,

I followed your instruction. The debug.exe ran but the zip file never showed up. I think I am going to return the product. The whole reason for me buying it was to use the 2 HDMI ports on the dock. I may as well just save the money and buy a USB multi-port adapter because that’s all that this dock is doing. For $139.00 I expected a better product. Sorry. I am very unhappy at this point.

Is there any way you could remote into my PC and see if you can fix this?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.