ud-ultcdl with Ubuntu Linux 16.04


#1

I’m trying to use a ud-ultcdl with Ubuntu Linux 16.04 on a Dell XPS 13. I’ve got USB keyboard and mouse, ethernet, one HDMI and one DVI monitor attached. I have installed the DisplayLink driver.

It’s proving to be quite unreliable. After booting up everything works for a couple of minutes but then the screens flash and a bunch of the peripherals die. Usually the DVI monitor, keyboard and ethernet but not always. The HDMI monitor plugged into the 4K slot always continues to work.

Powering off the docking station, waiting a minute and powering back on usually gives me a couple more minutes before it goes wrong.

There are a bunch of errors in dmesg:

[115.869055] usb 4-1.1: reset SuperSpeed USB device number 3 using xhci_hcd
[117.590186] usb 4-1.1-port1: Cannot enable. Maybe the USB cable is bad?
[119.074341] usb 4-1.1-port1: Cannot enable. Maybe the USB cable is bad?
[119.661325] usb 4-1.1: reset SuperSpeed USB device number 3 using xhci_hcd

I have tried a different USB 3 cable but had the same problems.

Any ideas? Should I try update 16.10?


#2

Hello Guy,

Thanks for contacting Plugable support. I’d be happy to assist you, though we do not do any testing or officially support this docking station under Linux.

With that being said, I suspect the problem may be related to the XPS not being fully updated. I would make sure you have the latest BIOS installed, and also the Thunderbolt 3 firmware - though that may require Windows to be installed. Also, try disabling WiFi momentarily and see if that helps. Some of these XPS systems are known for having their internal WiFi interfere with the USB-C port.

Do you have Windows installed as a dual boot? That would be a good way to narrow down the issue.

Aside from that, we could try sending you a different pretested USB-C cable.

Thanks,
Josh


#3

Hi Josh,

Thanks for getting back to me. I updated to the latest BIOS and firmware from Dell and that didn’t help. Next up I upgraded to Ubuntu 16.10 and everything is much more stable now. No more usb errors in dmesg, all the peripherals work etc. So I guess it was a Linux kernel problem… who knows?

We can rule out a problem with the USB cable I think.

Now, just to work out why the DisplayLink monitor is so laggy. I’ve tried it over HDMI and DVI and it’s the same. The HDMI monitor plugged into the 4K slot shows 60 FPS with glxgears. However the DisplayLink monitor gets 1 FPS with glxgears and other apps are very laggy on that monitor only.

Is it likely to be a hardware issue or something with the DisplayLink driver?


#4

Hi Guy,

Thanks for the update. Very interesting results, especially about the update to 16.10 making the biggest difference.

I’m not sure if the performance with DisplayLink and glxgears being so poor is expected or not. I wish I had a better sense of the performance on Linux. What I might suggest is to post in the DisplayLink forums and see if anyone there has any suggestions.

http://www.displaylink.org/forum/foru…

Best,
Josh


#5

Thanks, I’ve posted a new topic on the DisplayLink forum. Let’s see what they say.


#6

Has DisplayLink been able to give you any idea on expected performance?

Best,
Josh


#7