ud-ultcdl USB does not work unless resetting power.


#1

I have a ud-ultcdl and USB stopped working. The green light does not light. If I disengage the power cord and put it back, it starts working again. Any ideas why this would happen?


#2

Hello Robert,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

This can happen on occasion if the dock or the host system gets in a bad state, but it’s not something that I would expect to happen often. Can you tell me what model computer you’re using with the dock?

Also is this something that just started happening or has this been an issue from the beginning after setting up the dock?

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3

I have had the docking station for about a month. It seemed to work fine when I used my Lenovo laptop. but, last week I switched to a new MacBook Pro.
I have tried resetting the SMC on the Mac, but that had no effect. Since the problem started, I have tried several usb keyboards with no luck. Then I notice that the green usb light was not lit on the dock. When I removed the power cable from the doc and put it back in…the issue resolves…until I shutdown and restart the MacBook.


#4

sorry…correction
My old Laptop was a Dell Latitude 7480
My New Laptop is a new model Macbook Pro


#5

Hi Robert,

Thanks for the information. Interesting that you’re having these issues with the MBP that were not present with the Dell. We know the hardware in the dock is probably fine then.

Are you using the USB-C cable that shipped with the dock or a different 3rd party cable?

Also which model is your MBP? The 13 or 15 inch?

Thanks!
Josh


#6

I am using the usb-c cable supplied with the dock.
The MBP is 15”


#7

Hi Robert,

Thank you so much for working through this issue with Josh. He is out of the office today, but I wanted to make sure that we continued with attempting to identify the issue.

I appreciate you sending over the confirmation of the USB-C cable usage, and Macbook Pro model. Is this a 2016-2017 MacBook or an older model? I know that you have experienced issues with your keyboard, but do all connected USB devices experience the same issue? And is the issue occurring on all of the USB ports on the docking station?

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#8

Hi,
It is a new 2017 model map.
I have only tested the usb keyboard…but I assume all usb from the doc is not functioning since the green usb light is off until, I reset the dock power. I will double check on Monday when back at the office.
Thanks


#9

Hi Robert,

Thank you so much for clarifying, as well as continuing to run some additional troubleshooting. In the recent days, have you upgraded to MacOS High Sierra, or did your individual Macbook already come with MacOS High Sierra installed?

I appreciate you testing some additional items on the USB ports to see if it is specifically centered just around the keyboard. I would also suggest moving the docking station as far as possible from the system, and turning of WiFi and seeing if the same issue occurs.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#10

Hey Marc,

I am running Sierra (10.12.6). Work has not released High Sierra for us to use yet.

Interesting thing…While testing, When I first start my MBP…
-the green light is not lit
-Keyboard, mouse, camera that are attached to the dock do not work
-Laptop is about 3’ away from dock

If I plug a USB thumb drive into the dock…
-The green light goes on
-The thumb drive is recognized
-The other USB devices that were plugged in still do not work
-If thumb drive is unplugged…green light goes out.

Then if I unplug the power and plug back in everything begins to work fine.

I will shut down now with Wifi off and test again.

Thanks,
Bob


#11

I just tried with Wifi disabled. This made no difference.

Also, I also tried just unplugging and replugging in the keyboard. The green light did not come on and the keyboard did not work.

Why the USB thumb drive manages to be recognized, I have no idea. My guess is that there is some type of power issue that does not like the handshake coming from keyboards, mice or other accessories. (just guessing)


#12

Hi Robert,

I appreciate you working through these individual troubleshooting steps, and providing such great details. Based on the behavior, it sounds as if USB 3.0 devices are being read correctly (assuming the USB thumb drive is a USB 3.0 device) but the issue is really occurring when utilizing USB 2.0 devices (like the mouse and keyboard).

Being in an office setting, I was wondering if it would be at all possible to attempt to utilize and test the docking station while connected to another system, maybe a compatible Windows 10 system? If it is, this may give us better information for isolating the individual hub inside of the docking station as the issue, or one related specifically to your Mac and its current operating system version.

If this is not possible, just let me know, and our next steps may involve getting a pretested replacement unit sent out to see if isolating the hardware resolves the issue.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#13

I actually only received this Mac a few weeks ago…prior to that I was working with a Dell 7480. With that, the keyboard and mice worked fine.


#14

Hi Robert,

Thank you so much or clarifying, with this information in mind, then we are purely dealing with a problem associated with your Mac by itself. Normally in this situation we would advise making sure the system is on the latest available version of the operating system, but I completely understand that this cannot be done due to specific requirements by your IT Department.

I am absolutely baffled as to why this issue is occurring, other then it being specifically OS related and the device needing to be fully updated. Have you tried utilizing all of the available USB-C/Thunderbolt 3 ports on the system and experience the same behavior?

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#15

Hi Robert,

We have not received a response back from some of the additional behavior that you were experiencing, and we wanted to make sure we were putting as much attention on your issue as possible. If you would like to continue troubleshooting and attempting to narrow down the issue, please feel free to reach out to us directly at support@plugable.com, and we can work through some additional steps.

If anyone is experience the same issues, please do not hesitate to reach out to us as well, and we would be more than happy to assist.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#16

Yes…I have tried all usb-c ports. The issue still exists. I’m not sure what else to try.


#17