UD-ULTCDL + Dell XPS 13 + Ubuntu


#1

Hi,

I have a UD-ULTCDL that I’m trying to use with my Dell XPS 13 (9360) running Ubuntu 16.04 and two monitors, 1x Dell P2715Q (3840x2160) and 1x Dell U2715H (2560x1440).

I have the Dell P2715Q (3840x2160) plugged in to the 4k socket and the Dell U2715H (2560x1440) plugged in to the 2k socket.

On boot, it seems like no signal passes throught the 2k socket, the monitor does nothing at all.

Also, the 4k cannot be set to 3840x2160, as as soon as it’s attempted the screen goes black.

Have you any tips on something to try?

Thanks.


#2

Hi Benjamin,

Thanks for posting!

While Plugable officially supports Linux on many of our products, we do not support Linux with our UD-ULTCDL USB-C Triple Display docking station. We do our best to call out the supported operating systems in our Amazon product listing and on our Plugable product page -> http://plugable.com/products/ud-ultcdl/

That said, the 2K HDMI output inside the dock (as well as the DVI output) is powered by a chip from DisplayLink. DisplayLink also does all the driver development, and they have released a driver for Ubuntu 16.04 here -> http://www.displaylink.com/downloads/…

DisplayLink has a knowledge base here for more info: http://support.displaylink.com/knowle… as well as a forum where they are soliciting direct feedback for the driver here -> http://displaylink.org/forum/forumdis…

To the 4K issue, while I can’t be sure of the cause, the first thing to ensure is that you are using the USB-C cable included in the box with the dock to connect it to your system (3rd-party cables can cause problems) and that the HDMI cable is not the cause by swapping in a new cable that meets the HDMI 1.4 specification or higher.

In addition to checking the cables, we have found that with Dell XPS systems and Windows it is imperative to have all the latest system updates in terms of the BIOS, Thunderbolt 3 Driver, Thunderbolt 3 NVM firmware and GPU driver to ensure that USB-C devices work as expected. I wrote about this in detail if you are curious here -> http://plugable.com/2016/06/30/invest…

While you can update the BIOS from within Linux on the Dell system, to our knowledge as of today there is no way to update the Thunderbolt 3 NVM firmware from within the Linux environment.

In short, please try installing the DisplayLink Ubuntu driver, update the system BIOS, and check the USB-C and HDMI cables to see if that helps with the behavior. If it does, great!

If not, we never want a customer stuck with a product that does not meet their needs and we offer a 30-day no-hassle return policy for all products sold by Plugable Technologies and fulfilled by Amazon. You would just need to email your original Amazon Order ID number to support@plugable.com to get the process started.

Sorry for the long post, please let us know if that information helps or if you have any additional questions!

Bob
Plugable Technologies
www.plugable.com/support


#3

Well, I’ve solved a large part of my problem.

After some searching I came across this.

https://github.com/AdnanHodzic/displa…

First thing I did was run boot repair to install grub so that I could get around the UEFI issues.

Next I uninstalled my DisplayLink driver, and then installed via the software from the above link. Worked like a charm.

Still some teething issues (lag, etc…), but I have all screens running now.


#4

Hi Benjamin,

Thanks for getting back with the update, glad to hear the additional outputs are now working. Appreciate very much you sharing the link for the 3rd-party installation method for the driver.

Have a good day!

Bob


#5