UD-ULTCDL - 4K quit working


#1

I’ve been using for about a month and it’s worked perfectly, but yesterday, one of the three monitors quit working. The HDMI 4k port isn’t working. I swapped cables, checked monitors, et al. Nothing helped. Laptop is a Dell Precision 3530. After some further researching, I cycled the power off then back on again and the dock is now working again. But, is this a common issue?

Thanks,
Jason


#2

Hello Jason,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

The 4K HDMI port in the dock relies upon the host system to output video via USB-C VESA DisplayPort Alternate Mode. What that means is the system actually is sending the DisplayPort video signal out from its graphics card to the USB-C port, then out over the C cable to the dock where it is processed and converted to HDMI. The other graphics outputs on the dock are driven by the DisplayLink chipset within the dock.

If this continues to be a regular issue I’d suggest we grab some diagnostics on your system. It’s not something that should happen often, but it can happen from time to time. Sometimes in cases like this BIOS and/or graphics card drivers can help the stability of the Alt Mode video link between the host system and dock so that occasional power-cycles shouldn’t be required. Though, with some host systems updates may not be available.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/