UD-ULTC4K Stopped Recognizing Monitors after three years

I have been using my UD-ULTC4K for more than three years. It has two monitors attached to the two DisplayPort ports. I have a few USB item (webcam, wireless keyboard and mouse, sound bar) plugged into the UD-ULTC4K. It has been working great and starts right up when I turn on or wake up my laptop, which is connected with the provided USB-C cable. I have used a couple of different computers, including a Dell, a MacBook Pro, and an HP Elitebook. I have primarily been using the Elitebook for the last 18 months. Yesterday, I connected my MacBook Pro for the first time in a while. The monitors did not work, so I troubleshot it and ended up deleting and reinstalling the DisplayPort manager and unplugging and repluging in the the UD-ULTC4K. Then it all worked. However, when I switched back to the Elitebook, the monitors did not work again and I got an error that a USB device was not recognized. The things that I had plugged into the UD-ULTC4K USBs worked fine, but not the monitors or the devices plugged into the monitor USBs. I deleted and reinstalled the DisplayPort manager and unplugged and replugged in the UD-ULTC4K and eventually everything worked. However, this morning, when I woke up my laptop, then monitors were not working again. I unplugged and replugged in the UD-ULTC4K and it all worked, but I do not want to have to do that everytime my computer goes to sleep. Any suggestions on how to fix it so it works like it did yesterday morning?

Hello Rob,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

This is an odd problem but I think we can likely get things working again as expected. Since you just reinstalled the DisplayLink Manager on the Mac I expect that’s likely the latest 1.8 version. We may also want to ensure the drivers are also updated on the Windows system(s). If the DisplayLink drivers are really old on one system or the other, it can cause issues for the dock as the DisplayLink chipset in the dock can get into a bad state requiring an unplug/replug or worst case reinstalling the drivers again.

For the Windows system(s) here would be my recommendations to ensure the newest DisplayLink drivers are installed and are in a known good state:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Download, extract and run the DisplayLink cleaner tool, found here → https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+Installation+Cleaner+10.1.2860.exe and ensure it displays “Cleaning Complete” when done (video walk-through if you need it → https://youtu.be/AcVV1gD_FvI)

  3. Once the Cleaner has been run, reboot (even if not prompted to)

  4. Now download and install the 10.3 M0 DisplayLink software, found here → https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows10.3+M0-EXE.exe

  5. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

If all of the systems are up to date I’d expect that you should be able to move the dock between them pretty seamlessly.

If this doesn’t seem to help it might be a good idea for us to get some diagnostics from one of the Windows systems, especially when/if you run into the USB device not recognized error.

We have a troubleshooting tool that helps us find out what is going on in situations like this. If able, please plug the device into your computer, then go to this page and follow the instructions there:


When emailing us the diagnostics results please mention ticket 395306 in the subject line, please don’t post them here on our forum!

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

Thank you. As described in my post, I had done all of that, but at your request I did it again. It initially resolved, but upon my computer going to sleep, the monitors were again not detected when it awoke. I unplugged and replugged in the dock, getting the unidentifiable USB again. I pulled the logs and sent them by email, but I need a solution that last past the next sleep or restart.

I got ahead of myself. The plugdebug tool is stuck at “compressing,” so I cannot send the results. I tried it a couple of times. Any suggestions?

Hello Rob,

I’m sorry to hear the utility has gotten stuck during the compression step to create the zip file to send to us. Sometimes we’ll see this and still haven’t fully been able to figure out why, my apologies for this inconvenience.

Worst case we may need to continue without these diagnostics, though one thing that’s worked for some has been to run an older release version of the diagnostic utility from here: https://media.plugable.com/downloads/plugdebug/plugdebug-win32-0.9.1.exe

If it looks like we’ll be unable to get the diagnostics regardless of the diagnostics too version then we’ll just need to move on without them. For the Elitebook, please let me know the “product name” and “product numbers” for the system as the first step (for how to find these see here https://support.hp.com/us-en/document/c00033108).

This info should help me look up the full specifications from your system through HP and we can proceed from there.


I tried to run both the new and older versions of the tool and they both hung at the compression stage. The product name is HP EliteBook 850 G7 Notebook PC and the product number is 219U2UP#ABA.

Thanks for the update and for trying that, my apologies it hasn’t worked. I wonder if something is blocking it from completing, but no matter we can proceed without and I appreciate the system info!

Looking at this HP model the only additional recommendations I can suggest are the following that could affect the dock:

  1. If not already installed I do recommend to ensure the latest BIOS update is performed: https://support.hp.com/us-en/drivers/selfservice/swdetails/hp-elitebook-850-g7-notebook-pc/33386506/swItemId/ob-300346-1

  2. I would also recommend to update the Intel graphics drivers, often these are not kept up to date properly by Windows Update or even from HP directly. Here’s the latest version: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe (These drivers control the primary output of the dock and the DisplayLink drivers controlling the other two ports also tie into these graphics drivers as well.)

If the dock still isn’t recognizing monitors like we expect then I think as the next step I would like to send you a pretested (known-good) replacement dock under warranty to help rule out any hardware problems with your current dock.

If that looks like it will be needed, please email us at support@plugable.com with the following information so I can begin the warranty replacement process:

  1. In the subject line please mention ticket 395306
  2. Please let us know the Amazon order ID number or other proof of purchase
  3. Serial number off the bottom of the dock
  4. Best shipping address

I will then follow up with a reply email with tracking information once it’s been shipped out.

Of course if you have any additional questions I’ll be happy to answer them as well.

Thanks again!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.