UD-ULTC4K not recognizing Logitech C615 webcam

I’ve tried using a different USB port, no luck.
It worked with my old hub, but not with this one.
I’ve tried resetting my UD-ULTC4k, then plugging everything back in.
The drivers are all upto date, and I’m running out of options, I need the webcam…

Any help would be great.

Hi Alex,

Thank you for posting! I am sorry your docking station is not working as expected and I would be happy to help.

Thank you as well for the detail you provided and the testing you have performed that is much appreciated. Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 398598’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Richard A
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.