UD-CAM NIC not working

UD-CAM connected to 2019 MacBook Pro macos 10.14.6 does not display network interface in settings. All other settings on the UD-CAM work. Followed instructions on another thread for “Plugable Ethernet” and there is not an option for this in network settings. Also csrutil disable has been ran from a terminal window in recovery mode.

Please help. Thanks.

Hi John,

Thanks for posting!

If you haven’t tried already, let’s start by performing a power-cycle of the unit to reset its internal hub chipset. We’ve seen that this can often restore the dock back to a working state when one or more of its functions are not quite working. To do this, please follow these steps:

  1. Disconnect all USB peripherals and the Ethernet cable connected to the dock
  2. Disconnect docking station from host machine, then disconnect the power adapter from power
  3. Leave unplugged for 1 minute for power to dissipate
  4. Connect docking station initially into power only
  5. Connect docking station to host machine, then connect USB peripherals and the Ethernet cable, then test for functionality

If this helps, great! If not, I would recommend installing the latest Ethernet driver version here: https://plugable.s3.amazonaws.com/bin/Realtek/RTUNICv1.0.20.zip

Please let me know if this helps or not and we can take the next steps from there.

Thanks for giving us a chance to help!


Hi Mitchell,

Power cycling the device as you outlined worked. Thank you!!!

Glad to hear it! Thanks for updating us.

I’ll be closing this thread, but if you might come across any other questions or concerns, please feel free to open up a new topic or reach out to us at support@plugable.com. We’re glad to help.

Best wishes,