UD-CAM dock not charging Laptop when connected to dock

I have a brand new Plugable UD-CAM docking station, connected Razer laptop, and the laptop is not charging when plugged in thru the dock. Is this a driver issue, or something else? Thx!

Hi David,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be more than happy to assist!

Due to very specific restrictions inside of Razer system BIOS’s and the capabilities of their USB-C/Thunderbolt 3 ports, they are not compatible with many third-party docking stations. Currently, they have only marked their own eGPU enclosure as compatible with their systems. We make sure to point out Razer incompatibility in the compatibility chart at this link -> www.plugable.com/products/ud-cam as well as on inside of the documents available on the Amazon Listing.

I am sorry that you have run into this issue, but if you could reach out to us directly at support@plugable.com, we can work on the next steps for returning the unit.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/suppport

Hi Everyone,

We attempted to reach out to David to work through providing a refund, but we did not receive a response via this forum post. If anyone else is running into the same issue, or David would like to continue with our refund process, please feel free to reach out to us directly at support@plugable.com.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support