UD-CA1 & Late 2016 13" MacBook Pro Charging


#1

Just received by UD-CA1 and was very excited to try it out. Unfortunately my laptop does not respond to the unit very well. It keeps cycling from charging and battery although under system report I see the unit is providing 60W of power. Any idea what is causing the unit to operate incorrectly?

I have a late 2016 13" MacBook Pro with Touch Bar.


#2

Hi Daniel,

We replied via email to your direct inquiry, but are posting it here as well just in case the email didn’t make it through. Thanks!


Sorry to hear about the issues here – certainly sounds like something in the dock isn’t working as it should.

I think the best approach will be to have a replacement unit pre-tested in our labs and sent to you. Since you’ve already provided the Order and Serial numbers (thanks!) I’ll just need your preferred shipping address to get this arranged.

Thanks,
Gary


#3

I have this exact senario on mine. Just received the dock yesterday, brand new Macbook Pro late 2016 13", worked great for about 5 hours then started switching between charging and battery, happens now every 10 seconds or so, basically disconnecting and reconnecting the dock constant and laptop going from power to battery and back.


#4

Did you try using the cable that came with your MacBook’s charger? I purchased a separate apple charger and cable, the second “official” apple cable I purchased seems to work better. No charging drop outs now. That said, I still can’t figure out why the ethernet fails to connect.


#5

I will try using the mac one and see thanks for the advice. I wish I could help with the ethernet, but my ethernet works great.


#6

Ok that doesn’t seem to work at all, plugging my mac adapter into the USB-C port in the Plugable dock does not pass power, so it does not work at all without their power supply plugged in. Powering my Mac directly from the mac power adapter and plugging in the dock seems to make it work without problems, but defeats the purpose of the dock being one cable to plug into the mac, otherwise I can just use the mac digital adapter and accomplish the same thing for 1/3 the price.


#7

OK, I just reread your post and I think I get what you mean now, use the apple usb-c to usb-c cable on the dock to the mac connection - trying that now!


#8

So interesting results, the USB-c cable that came with my mac for the charger doesn’t pass any data, it charges my mac fine from the dock, but there is no video or USB working, seems that cable is a one way power only usb-c cable. The separate charger and cable you purchased maybe is a proper full featured cable. I also had a third party USB-C charger with a cable and it also will not pass data. For now dock seems fine if I also plug the mac into power directly in another USB-C port, so seems the dock is not providing enough power or something.


#9

Well when I used the new cable power seems to be fine and I can connect a couple different USB devices to the hub and they work. Ethernet still dead, recognizes it but never connects. I’m wondering if I have a driver issue or something … Just a side note when I compare the thickness between the cables I can see a slight difference between the two official apple charging cables. I believe you are correct about the cable not being a true usb-c 3.1 or Thunderbolt 3. Frustrating that apple would sell a cable for as much as they do and it’s not a full featured 3.1 cable or Thunderbolt 3 cable.


#10

Rob and Daniel,

Appreciate the additional details here! This is good info to help understand what’s going on when this behavior occurs.

Rob, can you please email support@plugable.com so we can get a few order details and arrange a replacement?

Daniel, did you have any luck with the updated ethernet driver we sent over via email? (If it didn’t make it through, please let me know and I’ll re-send.)

Thanks!


#11

The email did come through I just didn’t see it in my inbox. Will try it out later this afternoon.


#12

Ethernet is still not working. I actually decided to wipe my MacBook and reinstall my system this evening. The first thing I did after starting with a clean install was to install the new driver you sent. Unfortunately the ethernet adapter shows up but never shows a connection.

Here is something that might be helpful in troubleshooting. The green status light flashes with what I assume is a valid network activity … until I plug the docking station into my MacBook. After that the green light turns off and the orange stays solid.


#13

Out of curiosity I used a StarTech 0.5m ThunderBolt 3 cable I had purchased for my Samsung T3 SSD. Now the ethernet works and charging seems to be stable. Why didn’t the included cable work? I’m guessing the apple USB-C cable that I purchased could carry enough current, but couldn’t handle the data? … Disappointed. The StarTech cable works but I really need one > 6’ so I can place the dock under my desk and connect via one cable to everything.

Do you have a list of cables that will work with this dock that supports both the power requirements (60W) and correct USB-C standard?


#14

I have already replaced it with another one from Amazon and returned the first one. The new one so far has been working for an hour without issue, will report back on progress.

Rob


#15

Today is January 3rd, 2017.
Received plugable UD-CA1 on 12-30-2016 but didn’t take it out of the box until today.
No displays, network, or peripherals connected to UD-CA1.
Just power from wall to UD-CA1 and then USB-C cable that came from plugable to Late 2016 MacBook Pro 15" with touch bar.
At first Mac was charging. Then it started “dinging” every 7-10 seconds and the screen on the laptop dims. The laptop charges, then disconnects, lather rinse repeat.

I tried disconnecting the UD-CA1 from the laptop, waiting a few seconds and then reconnecting, same results.

I tried using a different USB-C port on the laptop, same results.

I then tried using the Apple USB-C cable. That worked, but I don’t want to have to keep reaching around behind my monitors to get my charging cable to take home every day. That is why I bought a docking station. Also, the Mac USB-C cable that came with the laptop/charger doesn’t seem to do data. When I connect a USB peripheral to the UD-CA1 while the MAC is connected to the UD-CA1 via the Apple USB-C cable, then USB peripheral is not detected. However, same USB peripheral connected to a USB-A USB-C dongle does work.


#16

I have the same problem :frowning:


#17

I sent mine back and got a second one and the second one has run flawlessly so far for 3 full days (first one worked for 5 hours before getting the disconnect reconnect issue). I have it on a 13" macbook pro with touchbar brand new 3 weeks ago and the dock is pretty loaded up, using hdmi, 4 USB devices including external HD and ethernet. Seems it is just poor QC or the mac to dock usb-c is poor quality and is easily damaged or hit or miss.


#18

@Ben Russo,

Appreciate the details Ben. In our continued testing, it seems like there’s some potential interference in play here with the high-frequency signaling. We’re only hearing reports of this from some MBP Touchbar owners. (Non-touch models don’t seem to exhibit this behavior as best we can tell at this point.)

The Apple cable will support power/charging, but not video – but regardless, certainly understand your desire for things to work through a single cable as intended.

A couple things to suggest:

  1. Can you please confirm you’ve installed the 10.12.2 Sierra update through the App Store?

  2. Can you please try disconnecting from Wi-fi and seeing if that helps?

Thanks!


#19

I confirmed that I am running the 10.12.2 Sierra update.
I disabled WiFi, and I am still getting the charging / not-charging (repeat) continuously. (Note: this is with the plugable UD-CA1 included USB-C cable. again, if I use the Apple cable then charging works continuously, but no docking station function other than power.)


#20

Same problem!