UD-3900H Intermittent flickering on dual displays


#1

Hi all, I am using the HDMI port and DVI port with two identical monitors. I am experiencing an annoying intermittent flickering/blinking on/off on both external monitors, usually at the exact same time or within a few milliseconds. My laptop is a Dell Latitude 7480 with Windows 10. I am using a USB 3.0 port to connect the Pluggable. I have tried a different USB 3.0 port with the same result. The DisplayLink drivers are version 8.5.3594.0. I also updated the Microsoft USB Superspeed Hub drivers to 10.0.17134.228. This has been happening on and off since I installed the UD-3900H in June. Any ideas would be very much appreciated.


#2

Hi,

Thanks for reaching out to us, I am sorry this is not working as expected.

Thank you for letting me know you have already updated the DisplayLink drivers and USB hub drivers. The next most common cause of this type of behavior is out of date graphics drivers. The Latitude 7480 uses Intel HD Graphics drivers which are available from Dell’s Download page here ( https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverId=DHV1V&osCode=WT64A&productCode=latitude-14-7480-laptop ).

** While most updates proceed without incident, there is always a chance something could go wrong. Prior to proceeding, please ensure you have a verified full system backup of any and all important data and please create a fresh System Restore Point as a precaution -> https://www.tenforums.com/tutorials/4571-create-system-restore-point-windows-10-a.html Plugable will not be able to help recover any data or restore the system to working state should an update not work as expected. * If you do not wish to take this risk, please stop here and let me know.* **

With the docking station disconnected, please download and run the Intel Graphics driver update from Dell and restart the computer when completed, even if not prompted to do so. When back at Windows reconnect the docking station and let me know if the flicking continues.

Please let me know if this helps, if not we can go from here.

Thank you,

Pat


#3

Hi, I followed your instructions and updated the display driver to 24.20.100.6286 (dated 8/15/18) yesterday. The blinking us still happening.


#4

Hi,

Thanks for updating the graphics drivers.

Based on your description of the behavior, our next step is to get some additional information from your system.

If you would, please keep the dock connected and both monitors attached and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to “support@plugable.com” with the subject line “Ticket #240774 - Attention Pat” as this will allow us to examine some log files from your system to help determine the next steps.

Additionally, the Latitude has both USB-C and USB 3.0 Type-A, does the flickering happen when using the USB 3.0 Type-A cable as well as the USB-C cable provided with the docking station? Can we test with the USB-C cable if not already tested, this will help to rule out a faulty USB cable.

Thanks,


#5

Hi Pat,

I will follow your suggestions and run the PlugDebug utility and send the results as you requested. I did not get a USB-C cable with the docking station with the docking station so the only cable I have tried is the Type-A.

If you’d like to send me one, I’d be happy to try it.

Thanks!


#6

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.