UD-3900: USB headset periodically stops working when plugged into dock


#1

When I disconnect my laptop (Dell 6430u, Windows 10 64-bit) from the UD-3900 (e.g. to go to a meeting) and later reconnect, my USB headset (Jabra UC Voice 750a MS) will sometimes fail to output audio (about half the time). The headset will show as connected in the Sound dialog, Playback tab, but when I right-click and select Test, an error dialog is posted that says “Failed to play test tone.” I have tried to restore operation by changing the default device, disable/enable of the headset, unlug/plug the dock, unplug/plug the headset, all with no success.

If I plug the headset directly into the computer after it fails to work via the dock, it still fails to work, which tells me the laptop has gotten into a bad state. The only way to get it working again is to reboot.

I can reproduce this by unplugging and plugging the dock, after 1-3 times of doing that, the headset will fail. I tried to reproduce this by unplugging/plugging the headset directly into the laptop and it never fails to work, so whatever problem is happening is a result of using the dock.

I checked for a new driver, but Windows says I have the latest driver installed.

I purchased the UD-3900 to replace the Dell D5000 Wireless dock, which deosn’t work with Windows 10. We have numerous instances of these, so if I can get this working, I will recommend the UD-3900 to other D5000 users.

Addition: I forgot to mention - this problem doesn’t happen when using the headphone and mic jacks; unplug/plug the dock and all works well. This is a possible workaround, but we primarily use USB headsets.


#2

Hi Roy,

Thanks for posting.

I’ve had a few reports of odd audio behavior on Win 10 systems. Though nothing that matches exactly what you’re seeing, plenty of similarities with “failure to play test tone” and having to either reboot or unplug/replug the device.

Some users have had luck with the following changes to their audio settings, though it sounds like you’ve already tried these steps:

https://www.youtube.com/watch?v=HIveM…

https://www.youtube.com/watch?v=NIomM…

If the settings changes/defaults don’t help, it’s looking like this may need to be resolved with a patch from Microsoft. (One of several threads covering similar behavior:
http://answers.microsoft.com/en-us/su… )

Also, can you collect a set of system logs at your convenience and send them over? Curious to see the driver versions loaded for the various hardware.

Log-gathering tool:
http://plugable.com/support/plugdebug

Please email the resulting .ZIP file to support@plugable.com and we’ll have a look to see if we can come up with any other suggestions.

Thanks!
Gary


#3

Hello Gary,

Thanks for the quick response. I’ll check the links you’ve provided when back at work and send the requested info.

I agree with you that it looks like a driver problem of some sort, timing related I think, which is exposed when using the dock.

An alternative I tried was to use a USB 2.0 hub (had a 2.0 available), connecting the dock to the hub and my headset to the hub. I tested a dozen times or so (unplug/plug the hub) and had no failures. I’ve ordered a USB 3.0 hub ($12) and will update here when I have confirmed that avoids the problem (fingers crossed, since the USB 3.0 speed change could cause the problem to return). If it works, I’ll be happy with that implementation as it returns me to pulling power and one USB to “undock” and go to a meeting.

Again, thanks for the quick response, suggestions and willingness to look at logs. I’ve been very happy with the video performance of the dock, just have to get this headset problem resolved (confident that will happen).

Roy


#4

I tried the solutions described in your links above (Restore Defaults, change format), no help. I ran the log tool (that thing takes a while to complete) and sent the resulting zip to support, with a link to this thread in lieu of a support ticket reference.

To set expectations - If you look at my log files and nothing of help pops out, no further contact is required. I’ll update here with the results of my 3.0 hub testing (I should have it in 2-3 days, gotta love that Amazon Prime 2-day shipping).

Cheers,
Roy


#5

Hi Roy,

Thanks for the logs. A couple things to suggest.

  1. I’m seeing drivers installed for a Fresco Logic USB controller that doesn’t appear to be present in the system anymore. These may conflict with the built-in USB 3.0 stack in Windows 10, so let’s get rid of them. Please go to Programs and uninstall the “Fresco Logic USB3.0 Host Controller” entry.

Please reboot after uninstall, even if not prompted. Let’s then retest and see if things behave any differently.

  1. If that doesn’t seem to help, I’m curious if stopping and restarting the Windows Audio Services might work. Let’s test the following when things are in a broken state:

-Open up Task Manager, click More Details, and go to the Services tab.

-Click the Description header to sort by name

-Find the Windows Audio Service (Audiosrv), right-click, and chose Stop

-After stopping the above Service, do the same with the Windows Audio Endpoint Builder (AudioEndpointBuilder)

-Confirm that both Services now show “Stopped” under the Status column

-Right-click the Windows Audio Service once again, and click Start (this should trigger an automatic restart the Audio Endpoint Builder Service as well)

Please let me know how things work with the above. If we get lucky and the Services approach works out, we could probably write a quick batch file to allow for a quick double-click automation of the disable/enable process as a temporary workaround.

Cheers,
Gary


#6

I uninstalled Fresco, rebooted, it failed on first unplug/plug of the dock.

I was now in a failed state, so tried the second suggestion above, where I stop the two services, start WA (which starts WAEB), still broke. Out of curiosity, I then tried the other options I had tried earlier (Restore Defaults, change Default Format, disable/enable), none were successful.

Some good things to try, so thanks, just none that worked. I’m an engineer in a technology company (I’m strictly software), so very familiar with “good ideas” that don’t pan out! :slight_smile:


#7

Hi Roy,

Appreciate the kind words! Was hoping for a “good idea” that actually served as a resolution rather than simply good in theory, but can’t win 'em all I suppose. :slight_smile:

Looking forward to an update regarding how things work with the hub that’s en route.

Cheers,
Gary


#8

Test results with the USB hub are good news/bad news.

Bad news is that I could reproduce the problem.

Good news is that I purchased a hub that has a power button for each port (see HB-UM43) and the problem doesn’t happen if the headset port is off when the dock is first connected, I wait for the displays to connect (2-4 seconds), then power on the headset port.

Interestingly, while testing this 40-50 times, the Plugable headset connection (the analog) exhibited the same failure, where clicking Test would result in the error dialog. Same recovery was required as well. I had to reboot to get it working again.

It will be a bit of nuisance to ensure the port is off before I undock/dock, but I believe that is what I’ll have to do.


#9

I have a similar issue. I have a Surface Pro 2 connected to a PLUGABLE UD-3900 and connected to this is a Plantronics headset that I use for Skype for Business. Almost every time I unplug the usb cable and take my Surface to a meeting, when I plug back in, my headset doesnt work. What Ive found that most of teh time I can go into device manager and delete the headset and let it re detect it, and then most of the time it works again. Sometime this doesnt work but disabling and enabling it fixes.
Its a pain when I forget to do tis and get a call come in and have no headset


#10

Hi Roy & Tim,

There are some audio fixes listed in the change-log for the next version of Windows 10 (build 10565). Too soon to tell if the audio fixes are applicable to this type of issue or not, as we’ve yet to receive any feedback (and we’re unable to reproduce the behavior in-house).

This new version can be installed by anyone who’s part of the free “Windows Insider” program, but there’s definitely some risk involved - it’s a pre-release version of the OS, which could have other, more serious problems.

Generally not recommended for use on critical systems given the nature of beta software (especially operating systems)! But if you’re feeling like it’s worth the risk to see if the issue is resolved (and can survive if something going wrong with the installation) it might be worth a try.

Thanks!
Gary


#11

Hi Roy & Tim,

There’s a new DisplayLink driver that’s been released today, which contains a new audio driver.

Highly recommend installing it, as it contains a preemptive compatibility fix for upcoming Intel GPU driver updates. The audio driver portion could potentially be helpful with the audio issues you’re hitting.

Can you give it a try when you have a moment and if possible report back with results?

http://www.displaylink.com/downloads/…

Thanks!
Gary


#12

Cool, thanks. I’ll give it a go if I have problems again. Installed the latest Win 10 preview yesterday and have had no problems since so I’m going to wait to see if that has fixed it first


#13

Ah, excellent - thanks. Will be good to know whether the Win 10 preview build alone does the trick even prior to the new driver installation.


#14

I’m running Win 10 Enterprise (build 10240) and installed the new Display Driver, same problem. Disconnect/Connect the doc resulted in a headset failure 4/5, disconnecting the headset before a dock disconnect/connect succeeded 5/5 (my current SOP).

I’ll wait for the official update rather than install pre-release via Windows Insider access, but I am hopeful the next Win 10 update will fix my problem, given TCDV’s post. I’ll try to remember to test and post my results here when I have installed it (I have no idea when it will be released).


#15

Appreciate the updated test results, Roy.

Not sure when the official release of the next Win10 build will happen, but “sometime in November” seems to be the consensus in the tech press so hopefully it’s not too far off.


#16