UD-3900, Surface Pro 4 with Docking Station and 3 external monitors resolution


#1

I’m wondering if there is a way to increase the resolution of my main 27" monitor when my surface is docked? My setup disables the Surface Pro monitor while docked so that i can use my main 27" screen and two 24" monitors on either side for working at my desk. The highest resolution it will give me in the list is 1920 x 1080 and the text on the screen just looks blurry and everything is huge.

Currently this is my setup

  • Surface Pro monitor disabled when docked
  • 24" monitor on left is connected to Surface Dock Display Port
  • 27" Monitor (Main) connected to UD-3900 via HDMI
  • 24" monitor on right connected to UD-3900 via DVI

Thanks for any help that you can give to me on this.


#2

Hi Mike, thanks for posting and for the description of the behavior you are seeing. Would you be able to let us know the brand and model of monitors you are using to connect to our dock? We mention on our Amazon product listing and product pages that when both the DVI and HDMI ports on our dock are in use the resolutions of the connected monitors will be limited to 1920x1200. Our dock can support up to 2560x1440 at 50Hz refresh rates, but only while a single HDMI connected monitor is being used.

Depending on the available resolutions of your monitors, it could be that you are limited to a 1920x1080 resolution. Unfortunately, there’s nothing that I could advise in order to achieve higher resolutions on the 27in monitor when there are two monitors connected to our dock at the same time.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

Hey there David,

Sorry for not replying earlier. It was my mistake. The highest resolution on those monitors was 1920x1080 but they were set to 125% that was making it blurry.

The UD-3900 is running it all perfectly right now., One last question is do you know a way to have all the icons go back to specific monitors when you have detached and then re-attached to the unit? Is there any way to set up profiles or something?

Mike


#4

Hi Mike, thanks for the reply and glad to hear that things are working now. You may be able to uncheck the Auto-arrange desktop icons setting to see if this helps the auto arranging of icons. You will want to right click on the Desktop, select View and then uncheck the Auto arrange icons setting (if it is checked).

If this does not help, the only other option that I can advise from researching is to use a 3rd party application like Desktop Restore (http://desktop-restore.software.infor…) to quickly restore the locations of the icons or DesktopOK (http://www.softwareok.com/?seite=Free…) to accomplish the same results. I haven’t tested these applications, personally, so I cannot speak to their success.

I hope this helps!

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#5