UD-3900 Plugable Ethernet Problem.


#1

Hello
I have the Plugable UD-3900 Dual Display Universal Docking Station running off of a windows 8.1 laptop. Everything seems to be working great except for the Ethernet piece. it’s always showing as disabled no matter what I do. i have tried uninstalling the driver then reinstalling it. Any ideas how to resolve this? note that the same Ethernet cable works OK on the laptop when plugged in directly.

Sam


#2

Hi Sam,

Thanks for posting. I’m sorry the Ethernet port on the dock isn’t working as expected. I’d be happy to help.

You may have already tried this, but just to be sure have you tried re-enabling the Ethernet adapter for the dock in the Network Connections application? You can right-click on the Microsoft logo on your desktop and select Network Connections to bring up the list of all the detected network adapters. You can then right-click on the Plugable Ethernet adapter and select Enable from the context menu that appears.

Assuming you have tried that, the next thing to look at is the lights by the Ethernet port on the back of dock to see if they are lit (you should see a green and amber light). If they are not that may be an indication that your are connecting to an older Ethernet hub that uses half-duplex communication, and our dock only works with full-duplex devices.

If the lights are lit, the next step would be to clean the DisplayLink driver for the dock from your system (this includes the driver for the Ethernet port) and re-install the latest version. Please follow these steps:

  1. Disconnect the dock from the computer and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step

  3. Download and run the DisplayLink cleaner tool, found here:
    http://displaylink.com/techsupport_fi…

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and run the 7.7 M4 DisplayLink software, found here:
    http://displaylink.com/support/sla.ph…

  6. Reboot, even if not prompted to

  7. Once you’re back in Windows, reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your PC which will trigger the final portion of the installation

Please let us know if our suggestions help (or any additional details), and we can determine the next steps and go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Thank you Bob for your response. I think the half-duplex like you said might be the cause. I’m looking into this in more details to get some clear insights.

Sam


#4

Hey Bob

Could there be any other reason why the device’s NIC light does not stay on ?

I have changed the Ethernet cable, I put a switch before the device, and tried in different rooms with a network jack still the device NIC LED will light up for 10 seconds exactly and then it goes off.

Sam


#5

Hi Sam,

Thanks for getting back to us, and thanks for doing the additional testing. The green LED should light and stay lit to indicate you have a physical connection, while the amber light indicates data transfer is happening by blinking. Given everything you tried there may be something going on in the hardware itself. To help determine this, the next step is to have you run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug and send the file it creates to support@plugable.com with ‘Ticket 98342’ in the subject line so we can match everything up and continue on directly.

Thank you,

Bob


#6

Here is an updated link to the cleaner too (step #3) -> https://s3.amazonaws.com/plugable/bin…

Please also note to use the most up to date DisplayLink driver in step #5 -> http://plugable.com/drivers/displaylink since the driver version changes as time goes on.


#7