UD-3900 external display and laptop display flickering / turning on and off / disconnecting


#1

Summary: The UD-3900 Docking Station only works on 2 of the 4 USB ports on my Dell XPS 15 Laptop. Use the left front USB port on a Dell XPS 15 Laptop.

This is a copy of my email sent to support, posted here for public information. I sent this email to support at plugable dot com with a zip file generated by the DisplayLink Support Tool found at http://plugable.com/support/tools/dis…

To Whom it May Concern,
I bought a UD-3900 on 7-1-2014. The following tests were conducted with no other USB devices plugged into the computer. Additional information about the computer can be found at the end of this post.

There is a problem with the UD-3900 when it is plugged into 2 of the 4 USB ports on my Dell XPS 15 laptop:

  1. When plugged into the left rear USB 3.0 port on my Dell XPS 15, the display disconnects every 5 seconds. Behavior is the same whether using the DVI or HDMI port on the the UD-3900. Windows makes a device attach/detach sound and the external display flickers on and off as if the display cable is being repeatedly unplugged and plugged back in. Network connectivity is lost simultaneously when the monitor flickers off. The UD-3900 USB hub works consistently however.

  2. When plugged into the right front USB 3.0 port on my Dell XPS 15, the UD-3900 DVI and HDMI display adapters and network adapter do not work (ever). The UD-3900 USB hub works however. This is similar to problem 1, except problem 1 is an intermittent malfunction, whereas problem 2 is a constant malfunction.

  3. (OK) When plugged into the left front USB 3.0 port on my Dell XPS 15, the problem does not occur. Everything works consistently.

  4. (OK) When plugged into the right rear USB 2.0 port on my Dell XPS 15, the problem does not occur. Everything works consistently.

***Every other USB device tested works flawlessly on all 4 ports of my Dell XPS 15, therefore this is not a problem solely with my Dell XPS 15. There may be a hardware compatibility issue between the Plugable UD-3900 and 2 of the 4 USB ports on my Dell XPS 15.

Information about my computer:
Dell XPS15-8947sLV 15-Inch Touchscreen Notebook - purchased new on 7/1/2014.
Dell P2314H 23-Inch LCD monitor
-monitor DVI port used for all tests.
-for testing the UD-3900 HDMI port, I used an HDMI cord and HDMI-DVI adapter.
Windows 8.1 updated to the latest patch.
McAfee All Access updated to the latest patch.
UD-3900 driver updated to the latest patch by downloading directly from plugable.com today (7/18/14). Verified driver is latest using Windows.


#2