UD-3900 Dual Display issues Flicker and screen anomalies

Hi I have a UD-3900 connected to ASUS Q500A, (W10), and an ASUS HDMI monitor. Presently i use the monitor as a main viewer and keep the laptop open as a 2nd monitor. I would like to add a 2nd full monitor but am unable to work with the laptop closed, (I don’t have enough room on my desk to keep the laptop open and add a 2nd monitor) When I close the laptop I get significant flicker on my monitor as well as the mouse starts to jump around the screen and other anomalies take place. I have updated to latest driver. Please advise a possible solution. Thank you

Hi Robert,

Thank you for posting! I am sorry things are not working as expected while using your UD-3900 docking station and I would be happy to help.

Thank you as well for the detail you provided that is much appreciated.

My impression based on your description is that everything works properly while the laptop lid is open. The problem only occurs when the laptop lid is closed.

Is my understanding correct? If not, please correct me.

Assuming for the moment that my understanding is correct, the specifications of your laptop indicate that it has two USB 3.0 ports on the left-hand side of the laptop and one USB 2.0 port on the right-hand side of the laptop.

If not already, may I ask you to please connect the dock to the single USB 2.0 port on the right-hand side of the laptop to see if that helps change the behavior when the laptop lid is closed?

Thank you for giving us the chance to help!

Bob
Plugable Technologies

Good morning Bob and thank you for the quick reply. The unit is presently plugged into the USB 2.0 port. I did try switching to the USB 3.0 to see if that changed the behavior but unfortunately I experienced the same results.

Thank you

Rob

Hi Rob,

Thank you for getting back to us with the additional information, and you are of course most welcome for the help.

Given that you did not correct my previous impression in regard to when the behavior occurs, my understanding is that it is correct. Please let me know if that is not in fact the case.

In regard to the issue at hand, our next step is to get some additional information.

If you would, please keep the dock connected to your laptop (while the lid is open) and please send the output of our PlugDebug diagnostic utility --> https://plugable.com/support/plugdebug to us directly via our direct support email address support@plugable.com with ‘For ticket #- 302185’ in the subject line.

This will allow us to match things up and review some log files from your system to help determine the next steps.

** Please also include the Amazon Order ID number for the UD-3900 purchase in your direct email **

** Please do NOT post the PlugDebug file or the Amazon Order ID number in our public forum **

Thank you,

Bob

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.