UD-3900 cannot adjust resolution on 2nd monitor. Also, detecting non-existing display


#1

I am not able to get full resolution out of my 2nd monitor, when hooked up through the Plugable unit.

I have a Lenovo ideapad 310 and an HP Pavilion V1M69AA#ABA w/ native resolution 2560 x 1440 @ 60Hz.

The max resolution it will give me is 2048 x 1152.

In the Display settings it is also showing a third monitor called DisplayLink 1, causing me to lose windows in the space I cannot see.

My Intel Graphics control panel cannot detect any other displays. Graphics driver Intel HD Graphics 620


#2

Hi Andrew,

Thank you for posting!

The UD-3900 can support a single HDMI connected display at up to 2560x1440 at a 50Hz refresh rate (it does not support 60Hz at that resolution). Looking at the manual for your display (https://support.hp.com/us-en/product/hp-pavilion-32-inch-displays/11516686/model/11516687/manuals?sku=V1M69AA) on electronic page 28 under ‘Preset Display Resolutions’, it does not appear to list 2560x1440 at 50Hz as an available option, so as a result it is dropping down to next available resolution option at 60Hz.

If running the external display at 2560x1440 at 60HZ is a requirement, I would recommend our UD-6950H docking station -> https://plugable.com/products/ud-6950h which can support up to two 4K displays at 60Hz (lower resolutions such as 2560x1440 at 60Hz also supported) as an alternative.

A quick note, the Intel Graphics Control Panel is not designed to detect or adjust USB-attached displays so the behavior you describe is expected (this is called out in the FAQ section of our UD-3900 product page).

Thank you,

Bob
Plugable Technologies


#3

Thank you. What about the 3rd monitor called DisplayLink that the native display control panel is picking up?

How can I get rid of that?


#4

Hi Andrew,

I cannot be sure of the cause of the ‘phantom’ display showing within the Display Settings application, however one way to mitigate the problem behavior would be mark the phantom display as ‘Disconnected’.

To do so, click on the number that represents the phantom display to select it. Then scroll down to the Multiple displays section and change the Multiple displays option to ‘Disconnect this display’ (example screenshot below).

Be sure to do this only for the phantom display, not the internal laptop display or the real display connected to the dock.While this will not remove the phantom entry entirely, it should prevent applications windows opening in places you cannot see them.

Thank you,

Bob


#5

That worked great. Thank you


#6

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.