UD-3000 not working after windows 8.1 upgrade


#1

After an upgrade from windows 8.0 to 8.1 the UD-3000 is no longer recognized on a USB 3.0 port connection. It does not register any problems in the Device Manager, it just does not function at all. It is recognized on a USB 2 port and functions in the USB 2 mode.


#2

Hi Michael,

Thanks for getting in contact with us. In all likelihood, there was a problem with the DisplayLink drivers not being properly updated upon the upgrade from Windows 8.0 to 8.1.

Can you please try reinstalling the DisplayLink drivers by following these steps:

  1. Disconnect the UD-3000 from the computer.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.4 M2 from the below link and follow the installation prompts.
    http://www.displaylink.com/support/sl…

  4. Reboot the computer,

  5. Replug the UD-3000 to the computer. Allow several minutes for the driver to enumerate and for the firmware to complete upgrade.

Please let me know if that helps. If you are still having trouble with your UD-3000 can you please run our log gathering tool Plugdebug, www.plugable.com/support/plugdebug, and send the resulting files to support@plugable.com.

Regards,

Stephen
Plugable Technologies


#3

HI,
Somehow the usb controller software went AWOL. Went to the Dell site and downloaded the newest update Renesas files and installed them. Problem solved. Thanks for your help.
Mike


#4