UD-3000 4 backside USB 2.0 ports not working


#1

Hi Plugable,

I purchased the UD-3000 SuperSpeed USB 3.0 Universal Docking Station several days ago, and on the initial use everything worked perfectly. However, since that initial use, the four backside USB 2.0 ports on the UD-3000 no longer work, along with the remaining USB 3.0 port on the front. On the first use of the UD-3000, I plugged a mouse into one of the four backside USB 2.0 ports, and despite a notification popping up saying that the driver for that port was not installed correctly, the mouse worked for the remainder of the time on I was on my computer that day. Now, however, the mouse’s bottom side doesn’t even light up when plugged into the UD-3000. And yes, I know that the mouse works, it works just fine if I plug it into my laptop directly. I have already updated all pertinent drivers (or at least I believe I have), I have uninstalled and reinstalled the driver for the UD-3000, the DisplayLink driver, and the Renesas/NEC USB3 Controller driver. I wanted to make sure I sought your advice, however, before I touched anymore drivers.

Pertinent Information:

(1) 4 backside USB 2.0 ports do not work; remaining USB 3.0 port does not work; USB 3.0 connection to laptop works, however.

(2) UD-3000 drivers up to date, as well as DisplayLink and Renesas/NEC USB 3.0 controller.

(3) “Unknown Device” has shown up in the device manager under Universal Serial Bus Controllers, driver failed to install for this unknown device.

(4) I may remember there being (I think, not 100% certain) a USB Composite Device or something else failing to install the driver correctly OR driver not found when installing the DisplayLink drivers?

(5) Have also tested flash drive on all USB ports on the UD-3000, still not working

So I came to ask, what should I do? If you have any suggestions for what drivers I should reinstall/update I’d be very happy to hear it. I have a ton of coding work to do this week so the sooner I can get this fixed the better.

Thanks,

Clark


#2

Hi Clark,

Thanks for posting, and thanks for the great background info. We’ll work to figure out what’s going wrong here.

It sounds like something at the lower levels of the USB stack – we sometimes see symptoms like this because corruption in the USB stack drivers (included in Windows). Or it could simply be a failing unit – unusual on the USB hub function of the dock, but can happen.

To help figure out whether it’s likely hardware or software, could you run our debug tool and email the .zip it generates to support@plugable.com? Here’s how:
http://plugable.com/support/plugdebug

With that, we’ll have enough information to figure out next steps. Thanks for your patience while we work to help!
Bernie


#3

Did this ever get figured out? I have the exact same problem. It just started about 3 days ago. Everything has been working great and then all USB ports stopped working on the device.

I have tried:

  • Restarting everything
  • Uninstalling and installing the latest DisplayLink software
  • Updating WIndows

#4