Ubuntu/USB 3.0 4K drivers don't auto-start upon boot

When I execute the .run file in the DisplayLink installer, it installs and activates the driver. Upon reboot though, the driver is not loaded, so I run the .run file again. I don’t know how to find the name of the module to put in (presumable) the /etc/modules

How do you make the drivers load upon reboot? What’s the right way to install these drivers?

Environment: Setup is a fresh install of Ubuntu 15.04 with a USB 3.0 4K HDMI adapter going to a 48" Sceptre TV running at 3840x2160. I also have 3 other 1920x1080 displays run off my ATI Radeon video card. Thanks!

Hi Rob,

Thanks for posting! While Plugable officially supports Linux on many of our products, we do not offer official support for Linux at this time for our USB 3.0 graphics adapters or USB 3.0 docking stations. We are aware that DisplayLink (who write all the drivers) has released a beta driver for Ubuntu 14.04 Linux but the driver is still very much a beta and we are still evaluating it.

Since you are using Ubuntu 15.04, the issue you are running into appears to stem from the fact that 14.04 uses an Upstart style init system as opposed to the systemd style in 15.04. There is a post in this regard on DisplayLink’s support forums here –> http://displaylink.org/forum/showthre… with a possible solution.

Since DisplayLink is soliciting feedback directly from those running the beta driver I would recommend posting in their Linux forum should that post not help in your instance –> http://displaylink.org/forum/forumdis…

For reference for anyone else monitoring this thread, DisplayLink has some good Knowledge Base articles with the state of the driver and Ubuntu support here –> http://support.displaylink.com/knowle…

Let us know if that information helps and we’ll go from there.

Thank you,

Plugable Technologies

Oh and if it helps, the release notes say to just run the .run file: http://downloads.displaylink.com/rele… and it also points here: http://support.displaylink.com/knowle… which does work, but I shouldn’t have to do that upon every reboot. Thanks!

Hi Rob, Did you see my earlier reply to your post?




First, thanks very much - this helps a lot! Using the technique on the first link, that seems to load the driver upon boot, and I can see the USB device, but in my ‘Displays’ screen where I would see the various monitor layouts, it no longer shows up there. So, the driver appears to get loaded, but the monitor is now no longer available!

I’ll post over on the DisplayLink site, I didn’t realize this was pre-production - thanks again very much!


Yes - thanks again!

FYI: It turns out the directions on this post, did work: http://displaylink.org/forum/showthre…

In my case, i was doing a soft reboot and was getting all sorts of errors. When I powered off the machine, waited, then restarted, everything worked as expected.

So, in case that link goes away, here are some pieces of the puzzle:

After running the .run to install the driver, if you need it, here is how to uninstall it:

$ sudo displaylink-installer uninstall

However, once installed, modify this file:

$ sudo nano /lib/systemd/system/displaylink.service

and add:


finally, run the following to have it load the driver upon boot-up:

$ sudo systemctl enable displaylink.service

then, power down your computer, and restart - and the monitor should come on around login-time.

Thanks again, Bob!

Hi Rob,

Thanks for getting back with the update and for sharing with our community what you have learned, we really appreciate it. Most interesting that the instructions from the original DisplayLink forum post did not work as there was at least one additional confirmation of success with those instructions.

I would encourage you to post your findings in that thread as well as DisplayLink has indicated they will be updating the installer package to try and accommodate both types of init systems in a future release, so the more detail they have the better.

Thanks again for sharing!


Hi There,
I’m about to purchase an USB3 to HDMI adapter for my Ubuntu 15 or 16 notebook.
Which Plugable device is recommended? I’d prefer the least expensive one; my monitor does not handle high resolutions.

Juan Lanus

Hi Juan,

Thanks for posting. Our policy hasn’t changed since my original reply to this thread in that while Plugable officially supports Linux on many of our products, we do not offer official support for Linux for our USB 3.0 docking stations or USB 3.0 video adapters.

Sorry we couldn’t be of more help!