Ubuntu Linux Support USBC-768H4

Is there any way I can get this to work on an Ubuntu computer (i.e. linux). I know there has been some other questions about this. Some refer to this webpage (https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu). But I tried installing the ubuntu dmg type file, and it would not work. The bash script specifically has OSX type header. Please let me know if there is any way to get this to work, even its technical. Otherwise I will have to send this product back. If not possible, do you know a product that is similar that will work with linux? (FYI it worked fine on my mac, but I need this for my work computer which is ubuntu). Thanks.

Btw, what is the mac requirement? Is there a way I could modify the code to make it work on linux? If so I could publish it for you guys so others can use it. Other than zsh in new macs, not sure what else is so different that it would not work without minor mods to some of the setup scripts.

I’m guessing its a firmware issue? Whats the reliance on internal GPUs and such?


Thanks for contacting Plugable! I will be happy to share some information with you regarding our USBC-768H4 and Linux support.

Unfortunately at this time we do not provide support for Linux. With that said the Ubuntu driver is the only one available for Silicon Motion products that we are aware of.

Please let us know if we can be of any additional assistance.

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.