UASP with WIndows 7 and the lay-flat dock?


#1

I just received one of your “lay-flat” USB 3.0 drive docks, and it seems to work really well. I currently have this plugged into a Toshiba C855 laptop (Intel I3 processor and Intel chipset). I’ve done some initial testing with an M4 SSD in the dock and that has worked extremely well. Now, I’m wondering if it’s possible to use UASP with the dock and this laptop? I know that the dock supports UASP, but can’t find a UASP driver for WIndows 7. I do dual-boot the laptop with Win7 and Win8, so I’ll try Win8 in a bit, but Win7 is really my main OS, so I’d really like to get UASP with that. Since you all seem to be up-to-speed on that, is there a way to do that (UASP on Win7)? Thanks, Jim


#2

Hi,

I booted into Win8, and I can see that the dock (and the SSD in the dock) is connecting using the UASP device/port, so that’s good, but as I said, I’d really like to get UASP when I boot into Windows 7. Not sure if that’s even possible, but I figured that I’d ask, since you all seem to be so up-to-date on “all things USB 3.0” :)…


#3

Thanks for posting to ask! Yes - with Windows 8 you’ll get a UASP performance boost automatically.

To use UASP and see a benefit, every layer of software has to support it, and there’s a licensing cost involved.

With Windows 8, Microsoft has implemented all that support and paid any licensing costs (assuming you’re running the built-in Microsoft USB 3.0 stack – which runs on nearly all USB 3.0 host controller hardware except for a few early host controllers like the 1st gen Fresco ones).

On Windows 7, the situation is much more complicated. Each host controller generally has its own matching USB 3.0 driver stack written by the chipset vendor (Intel, Renesas, VIA, Fresco, TI, etc.). And, perhaps because of the licensing costs or the extra driver support, very few added support for UASP in released versions. There are some reports that certain ASUS motherboards had a 3rd party driver (by MCCI). See here for details:
http://www.tomshardware.com/reviews/u…

So even with docks that support UASP like ours, the situation on Windows 7 is messy to take advantage of it.

Fortunately, the jump from USB 2.0 BOT to USB 3.0 BOT is by far the biggest gain. UASP just adds to that USB 3.0 advantage.

Hope that background helps. Thanks again!
Bernie


#4

Hi Bernie,

Thanks.

One of the PCs that I’ve built actually has an Asus mobo in it, with their “Turbo” USB 3.0 (it’s a P9X79 LE), but I’ll probably not be using the lay-flat dock with that much, as it’s intended to be used mainly with my Tosh C855 laptop. Maybe Intel will add UASP support one of these days, but it seems like they’re busy with Thunderbolt nowadays, and not paying much attention to USB 3.0?

As I said, I can confirm that Win8 connects with this dock with UASP. I guess that I have to think about switching to Win8 as my main OS, but I have some stuff that won’t run on Win8 yet.

Anyway, thanks again, and, BTW, this seems like a very nice product, esp. after spending a bunch of time testing other docks (see my other message about the activity indicator though :))…

Jim


#5

Hi,

FYI, you might be interested in the following: While, as I said above, in Win8, the lay-flat dock does connect via UASP driver, when I actually tried to use lay-flat dock with Win8, doing a copy of ~70GB from the Toshiba laptop to an M4 SSD in the dock, I had similar stability problems as I had previously with other docks/external enclosure with Win8, i.e., the connection and/or drive or files would disappear.

I checked if Intel has an Extensible Host Controller for USB 3.0 for Win8, but it appears that they do not. Their website said that Microsoft is providing those drivers, and that was what was shown in Win8 Device Manager… the drivers were all from Microsoft, dated from 2006.

So probably at this point, I’ll stick with using the lay-flat dock with Win7, which is really what I wanted to do anyway, and have to forego UASP support until such time as Intel provides that support (Intel does have the USB 3.0 drivers for Win7).

To paraphrase what you said, the whole situation with USB 3.0 in general, seems to be “complicated”.

Thanks,
Jim


#6

Hi,

I was still hoping that maybe I could get the dock to work well in Win8, and I found this article on your website:

http://plugable.com/2012/12/01/window…

and I tried that, and was able to install the Intel drivers.

However, after installing the Intel drivers, whenever I plug the dock into the laptop’s USB 3.0 port, the laptop is not seeing the SSD that I have in the dock.

I can see the UASP device in Device Manager, but even after unplugging and plugging the USB 3.0 connector back into the laptop’s USB 3.0 port, I don’t see anything attached to the UASP device.

Do you have any idea why that might be?

For the moment, I’ve uninstalled the Intel drivers in Device Manager, and then I can at least see the lay-flat dock and drive.

Jim


#7

Hi Jim,

I’m not sure why the SSD is not working with Intel-on-Win8, but you’re right - Since you’re looking to get UASP support on Windows 8, going the route of replacing the Microsoft drivers with the Intel drivers isn’t going to pan out, because it will disable UASP anyway.

Definitely a tangle!

When you hit difficult issues with a Microsoft-provided stack, one good thing to test is trying to recreate the problem with USB Selective Suspend off. Here’s how:
http://www.zazaknowledge.com/article…

Selective suspend is a feature who’s primary purpose is to save laptop battery by letting the CPU sleep more frequently (because it doesn’t have to manage the USB schedule for USB 2.0 devices that have been suspended). It’s a marginal gain in a non-battery-power case, but it’s highly complex to do, and is often the cause of compatibility problems and bus disconnects, etc. Something worth trying.

But overall given what you’ve said, Windows 7 without UASP might be the best bet until Windows 8 has a chance to mature a little more.

Hope that helps. Sorry there isn’t a more clear choice to take advantage of UASP!
Bernie


#8

Hi,

I think it’s working with Win8 now. There were a couple of things that I had to change, so I’m not sure which one or ones fixed things:

  • I don’t think that the uninstall of the Intel drivers was complete. Luckily, I had a backup image of Win8, so I restored that, but still had some problems when using Teracopy to copy about 40GB of files.

  • I disabled the selective suspend, but still had problems.

  • I think the last things I did were (1) in Device Manager, I set the SSD to “quick removal” (no caching) and in Teracopy, I unchecked the “Use system write cache”.

After all of that, the copies went perfectly.

I tested with the lay-flat dock plugged directly into the USB 3.0 port. I got copy speed of about 85MB/s and test speed of about 125MB/s.

I also tested with the lay-flat dock plugged in via a USB 3.0 hut (unfortunately, not a Plugable one… yet). I got copy speed of about 65MB/s and test speed of about 158MB/s.

So it seems to be working ok with Win8 now.

I don’t remember exactly the speeds that I got with Win7, without UASP, but I don’t think that the difference was that huge.

I do think that the last 2 things I did (setting the drive policy to “quick removal” and unchecking the “User system write cache” in Teracopy) were what made this work. On various forums, I’ve seen messages that with Teracopy, it’s better to turn off caching in Windows . That seems somewhat counter-intuitive, but seems to be correct.

Jim

P.S. As I said, I’ll probably be getting one of the Plugable USB 3.0 hubs soon. I’m debating between the 4-port vs. the 7-port. I really only need the 4-port, but the newer Asmedia chip in the 7-port is attractive to me. Do you all have plans of updating the 4-port hub to the newer Asmedia chip at some point? Just wondering…


#9

Hi Jim - Thanks so much for that detail!

Actually, the latest VIA VL812 chipset and firmware in the 7 port hub is mostly fixes for Mac, and it has created some new minor issues for Windows 8.

Whereas the 4 port hub with VIA VL811, we don’t have any known issues on Win8 (with shipping or latest firmware at http://plugable.com/2012/12/02/vl-811…).

We’ll be moving all of them in time to the VL811+ or VL812 (and eventually later chips), but there are no chip changes on the horizon for either product in the next 2-3 months.

Hope that helps. Thanks again!
Bernie


#10