Touch Screen not responding in multi-monitor setting

I have two Acer touch-screen monitors connected to the UD-3900 docking station. The docking station is connected to a Lenovo Yoga 2 Pro running Windows 8.1. I’m having trouble with the touch function of the external monitors. Some times I can make it work on all 3 screens, most of the time I can’t. When I get it working and turn the machine off, I come back the next day and the touch function is not working. The first fix was the “Tablet PC Settings” suggested in a different thread, however this no longer fixes the problem. Any suggestions?

I also have the same issue, Lenovo Yoga 2 Pro running Windows 8.1 Professional. I have dual Lenovo 23" touch screens, the screen is responsive on them but it tags the response on the main display. I.E. If I swipe left on one of the monitors, the left windows screen pops out on the main display rather than the actual monitor itself.

Hi All,

(Dehn, we sent a support email regarding your post but did not receive a response. I’d be glad to resend it if you’d like.)

Joseph, have you already gone through the “Tablet PC Settings” configuration to setup the multiple touch screen functionality as well? Going through the calibration process usually resolves issues where the touch input isn’t being mapped to the correct monitor.

To get there, you’ll want to navigate to: Control Panel > Hardware and Sound > Tablet PC Settings > click the “Setup” button next to “Configure your pen and touch displays”.

This will take you through a quick calibration process after which Windows should (hopefully) start registering the touch input on the proper displays.

Please give it a try and let us know how it goes! If we proceed with additional troubleshooting, it will probably be best to do so via our private ticketing system - feel free to email us at and we can get the process started if necessary.


Thanks Gary, just got done doing this a little while ago, resolved the issue for me.

Hi Gary;

I did receive the email - thank you. My apologies that I fell off the face of the Earth there for a while.

The problem still persists. The only way I have found to combat the issue is to connect everything to the UD-3900, experience the problem, then turn off the monitors and unplug the power supply from the UD-3900. Most times, when the device comes back up, everything will be working properly - however there are occasions when I need to repeat this process more than once.

I will address the questions in the Support email I received;

* The touch-screen is the only functionality that seems to be impacted; everything else connected through the device is fully functional.
* The “Tablet Config” option worked a couple of times, but eventually I could only get the calibration set-up to display on one screen; whereas when this process worked before, the calibration set-up displayed on one screen, then moved to the 2nd, then moved to the 3rd without any intervention on my part.
* Moving the touch-screen USB cables to different ports has no impact.

As mentioned earlier, I have found a work-around that seems to resolve the problem, however it’s inconvenient and I am disappoint that I have to go through this process frequently. I managed to talk the IT department at my work into allowing the installation of the drivers for the UD-3900 on my work laptop (which doesn’t seem to suffer the same issue - oddly, another Lenovo, different model) and I don’t think they will allow another change, so I will probably keep the 3900 to use with my work machine and perhaps I will try another USB docking station to use with my personal machine. Hopefully something can be done in an upcoming update that will resolve the problem.

For what it’s worth, I’m very happy with Plugable’s response to my posting and to other users questions that I have noted on other forums. Thank you!

I am running Windows 10 and an HP Envy touchscreen laptop. I have an ACER T232HL touchscreen monitor and another monitor that is not touchscreen. When I connect the pluggable device. the touchscreen functionality stops working on the ACER. This is after I successfully calibrated the ACER touchscreen without the pluggable device. What is the solution to this issue?

Hi Susan,

Thanks for posting!

A quick addendum as this is a very old support thread is that while we don’t officially support touchscreen displays via our docking station in many cases they can be made to work properly. Your description seems to indicate that the touch inputs may be attributed to the wrong display. Since you in essence have two touch screens (the HP Envy and the Acer monitor) it is possible that Windows is getting confused.

Search for the word ‘Calibrate’ from the Start Menu and select the result for ‘Calibrate the screen for pen or touch input’. From the window that appears select the ‘Setup’ button from the ‘Configure’ section and follow the wizard to identify which screens are touch-enabled. Once complete, select the Acer monitor in the ‘Display’ drop-down box under the ‘Display Options’ section and select ‘Calibrate’ and then follow the wizard (example screenshots attached)

Let us know if that helps when you have a moment, and we’ll go from there.

Thank you,

Plugable Technologies