To get back online after returning to my computer (GalliumOS 2.1 based on Ubuntu 16.04 LTS), I often need to unplug and replug my USB2-E100


#1

I have a USB2-E100 attached to an Acer C720 Chromebook which is running GalliumOS 2.1 which is based on Ubuntu 16.04 LTS. Normally I am able to access the internet via the USB2-E100. But when I leave my computer for, say, an hour or more regardless of whether or not I put my computer to sleep, I am often, but not always, unable to “get back online” unless I unplug and replug the USB2-E100 or restart my machine. By the way, my computer does *not* go to sleep automatically.


#2

Hello Lillian,

Thank you for your message.

Have you tried the adapter on another system? If you have, does it have the same behavior?

It would also be preferable to try the adapter on another network.

This isn’t typical behavior, and I’m not sure what the culprit might be. If the behavior is the same on another host we can certainly help to arrange a replacement under warranty.


#3

Hi Andy,

Thanks for replying quickly to my message.

You asked, “Have you tried the adapter on another system?” I’m not sure what you mean by another *system*. Do you mean another *machine*? I do have a second Acer C720 machine which is also running GalliumOS 2.x (I think it is running GalliumOS 2.0 instead of GalliumOS 2.1) which is based on Ubuntu 16.04 LTS. It also exhibited the same problematic behavior which I described in my initial message.

You indicated, “It would also be preferable to try the adapter on another network.” I’m not sure what you mean by *another network*. Do you mean another internet service provider? We currently have high-speed internet access through our cable company. It would be expensive and time consuming to set up an internet account with the local phone company to check the modem.

I was hoping you guys might have some sort of Linux script that I could download that would automatically reset the modem (perhaps by resetting the modem itself directly or perhaps my resetting the USB port which the modem is connected to thereby indirectly resetting the modem) whenever the computer were to either remain on but idle for x minutes (where x would be a user defined value which I would probably initially set to 30) or wake up from suspend (sleep).

Thanks,

Lillian


#4

Hello Lillian,

Thank you for you reply. I apologize for any miscommunication on my part.

By another system I had meant another computing device besides the Acer that you were reporting problems with. Be it a compatible Android phone, tablet, or another ChromeOS device. This was to help rule out whether the particular system being used was an issue and hopefully rule out some other factors.

By another network, I had meant any other wired connection even if it only had LAN access, to check if perhaps it was an issue with the particular network port that was attached to the other end of the network cable or possibly the whole of the equipment at the other end of the network cable.

I don’t know if this is an issue with GalliumOS, a particular issue with the Acer model being used, the network connection used on the other end of the cable, or the adapter itself. At the very least the information provided rules out that it is an issue with the particular computer that you were originally reporting issues with and narrows the issue down to one of those aforementioned factors (of which there are still several possibilities).

I don’t have a reset script as this isn’t normal behavior, and isn’t something that should need to be done. Usually behavior like this would make me think that there is an issue that exists somewhere that can be resolved or that there may be some compatibility issue.

I would be interested in getting some more technical information about the system via logs collected using the command below.

lsusb \>\> ~/Desktop/plugable\_data.txt && sudo ifconfig -a \>\> ~/Desktop/plugable\_data.txt && cat /proc/version \>\> ~/Desktop/plugable\_data.txt && sudo tar cvf ~/Desktop/syslog.tar /var/log/syslog\* && sudo chmod +rwx ~/Desktop/syslog.tar && dmesg \>\> ~/Desktop/plugable\_dmesg.txt && cat /etc/\*-release \>\> ~/Desktop/plugable\_data.txt

Please send the plugable_data.txt, plugable_dmesg.txt, and syslog.tar files as an e-mail attachment to support@plugable.com with the subject line “For Ticket #175321

I look forward to receiving your e-mail.


#5

Hi Andy,

Thanks for your quick and thoughtful response.

We have several Android phones and a third Acer C720 that connect smoothly via Wi-Fi to our ISP (our local cable company) via the router and modem in our home.

We have an old Windows XP computer that my husband uses to play computer solitaire on that has a wired connection. We very rarely use it to go online (we know it’s very insecure), but never have had a problem similar to the one I initially indicated in this thread.

I posted the following files you requested in your penultimate message:

  1. plugable_data.txt
  2. plugable_dmesg.txt
  3. syslog.tar

on Google Drive at:

https://drive.google.com/drive/folder…

Thanks,

Lillian


#6

Hello Lillian,

I’m sorry for the wait, I’ve been trying to make some more conclusive determinations regarding what is happening.

From what I see in the logs, the system was last put through a full boot cycle on Mar 9 @ 22:44:56.

There’s a lot of odd behavior from NetworkManager and it seems like it isn’t configured well for handling the wired network adapter and has specific rules in place for managing the wireless network connection.

If you extract the syslog.tar file that was generated via the command I sent, then look at syslog.5, you can see what I’m referring to. I think this might be a bug of some kind with how GalliumOS’s NetworkManager is configured for handling wired connections. One of the main issues seems to involve the interface being renamed and warnings about the device entering an unmanaged state.

Mar 10 10:51:57 lillian-Peppy NetworkManager[10288]: [1489171917.4259] device (eth0): interface index 5 renamed iface from 'eth0' to 'enx8cae4cf95035'

This does seem like a software issue though.

I’m sorry for not having more definitive answers, but I hope the logs at least help with investigating the NetworkManager issue further.

Since I can’t resolve the issue, I can help with a refund if you would like, but it may be resolvable either by updating NetworkManager and/or GalliumOS itself.


#7

Hi Andy,

>> If you extract the syslog.tar file that was generated
>> via the command I sent, then look at syslog.5,
>> you can see what I’m referring to.

Thanks but I am not “Linux technical” therefore I did not bother because had I tried to decipher it, it would have presumably been all Greek to me.

Also, thanks all of your help and for your offer. However, I bought the USB2-E100 modem used on eBay in August 2015 for $9.25. I neither expect nor want a refund.

I suspect my problem is being caused by a glitch/bug in GalliumOS 2.x because of the following (which I just came across about 15 minutes ago):

https://github.com/GalliumOS/galliumo…

The first comment in that thread by the user with the name “dymky” prompted me to remember that the problem described in this topic (aka technical support ticket) did not occur with GalliumOS 1.x

Thanks again for all of your help and for your offer,

Lillian


#8

Hello, I am a GalliumOS developer, who was assisting this customer on our own issue tracker at https://github.com/GalliumOS/galliumo…. I was in need of a USB ethernet adapter recently so I went ahead and purchased one of the Plugable USB 3.0 Gigabit ethernet adapters available on Amazon. I’m happy to say that it went smoothly and I was unable to reproduce this issue on my Acer C740 using that adapter. Unfortunately, that still leaves an unsolved issue that we would really like to get worked out if possible. Maybe there are significant differences in the chipset between the gigabit adapter that I used and the 10/100 adapter that the customer was using?

Update: I did a little more research, and apparently Ubuntu 16.04 made some changes to the way network management is done, which could be responsible for the bizarre names given to the adapters (I use Arch Linux and Debian primarily, so I’m not too familiar with the internals of a bare Ubuntu system). I don’t know if this could be responsible for the other issues, however, especially given that my adapter did have the same sort of strange name, but did not experience the same issue.


#9

Hello Colton,

We saw a pattern of issues like this in March of this year, including on some other Ubuntu distributions, but I haven’t seen this issue crop up again for the last couple months, so I think this issue was likely resolved at some point recently.


#10

Interesting, I will do some further research to see if GalliumOS has outdated versions of networking tools that could be causing the issues, as well as asking the user in question to update their packages and see if they can still reproduce the issue. Thank you very much for your input on this issue. Maybe we’re finally getting close to being able to put this one to bed. :slight_smile:


#11