Thunderbolt 3 DP2x will not connect on Dell XPS13 9350


#1

Hello - I’m having an issue where I can’t connect the TB3DPX2. For whatever reason I can’t get the DP2X connected. I’ve set the monitor to the DP Input but the adapter won’t let me connectt. Any guidance?

BIOS = 1.4.4 June 2016
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1487081/settings_inline.PNG?1474509832)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1487081/settings.PNG?1474509832) !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1487083/TB3Settings_inline.PNG?1474509877)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1487083/TB3Settings.PNG?1474509877)


#2

Update 3 - Solved problem:(Win10 Anniversary Update)

  1. Turned Airplane Mode On (As suggested in other posts/on site) which recognized and successfully attached the DP2x and passed the DP signal to the monitor
  2. However, once I tried to connect to wireless the DP signal dropped and the DP2x was no longer attached.
  3. Dropped power level to Wireless to 75% and this didn’t work.
  4. Dropped power level to Wireless to 50% and success.

Hope that helps anyone else with the same problem. This is my girl friends notebook, so if she’s not happy the house is not happy :wink:

Not sure what the root cause is on either Dell/Intel or Plugable sides (I imagine it’s either Dell/Intel)


#3

Hi Wes,

Thanks for posting, and thanks for the follow-up letting us know you got things working. I cover this behavior (and recommended workarounds) in more detail in my post on the subject -> http://plugable.com/2016/06/30/invest…

Very interesting that in your case the Wi-Fi transmit power needed to be lowered to 50%, thanks for taking the time to test that and share the results. Given the behavior we have seen helping other customers, we suspect the root cause lies with Dell and/or the Dell-branded wireless adapter (made by Broadcom). In the comments to my blog post there are reports of customers replacing the internal Dell Wi-FI adapter with an Intel branded one and that helping with the behavior.

Thanks again for sharing your results!

Bob
Plugable Technologies
www.plugable.com/support


#4