There appears to be no connectivity in addition non of my USB3 or USB2 devices connect


#1

The green light is visisble on the Power supply and I did have blue LEDs once, but no connection as far as the USB devices. I tried unplugging all devices and replugging them in using the order that you described to another user. Nothing has worked thus far.


#2

Hello Robin,

Thanks for contacting us again! We’re sorry that your hub is still not working. Thank you for confirming that you’ve tried a full hub reset. I also appreciate you mentioning the activity of the LED lights. If you haven’t already, please try plugging the hub’s USB cable into a different USB port on your computer (if available) to see if that corrects the hub’s behavior.

Also, you stated that you had blue LEDS once. Are any of the blue LEDs lights over each port lighting up when a device is connected? If so, can you please tell me what ports are lighting up (if any)?

We also have a troubleshooting tool that helps us find out what is going on in situations like this. Please keep the hub plugged into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Once the program finishes running, please send the .zip log file it creates on your desktop as an email attachment to support@plugable.com. We’ll review the logs soon after receiving them and determine the next steps from there.

Thank You,

Amanda
Plugable Technologies


#3