The curse of the windows update


#1

After the latest Widows update (April 2017), the video output on by Pluggable USB 3.0 dual monitors has stopped working.Any suggestions?

Toshiba Satellite Pro with Windows 7 Pro 64 Bit o/s


#2

Hi Chris,

Thank you for reaching out to us! I am sorry that you have had an issues regarding your Plugable UD-3900 Dock, but I would be happy to assist.

Most likely what has occurred is, when Windows performed the newest “Creators” update, it reverted some of the DisplayLink drivers back to older versions. My suggestion to attempt to resolve the issue would be to perform a clean install of the dock, and update all of the associated software and drivers. If you could, please follow these instructions:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.2 M0 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please click the ‘Skip’ button to allow the process to complete and then reboot the system.

Let me know if this garnishes any immediate results!

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Thanks Marc.

I followed the instructions and all is now well.

Thank you.


#4

HI Chris,

That is fantastic!Thank you for working through all of those steps, I know it can be time consuming but I am glad that the clean install was able to rectify the issue. If you have any other questions, don’t hesitate to reach out and let us know at support@plugable.com.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#5