TBT4-UDZ not working


My Thunderbolt TBT4-UDZ worked great for a few months. I tried to plug it into an older Dell laptop and it didn’t work. I’ve not plugged it back into my Samsung Galaxy Book3 Ultra and it is no longer working.

I’ve tried power cycling laptop several times as well as removing the power from the docking station for several minutes and plugging back in. I’ve also tried uninstalling - cleaning using the Display Link tool - and reinstalling the latest drivers. I’ve validated that the TB4 cable can charge and shows data for my cell phone. The white light is lit up on the docking station. Please help!

I’ve since tried a second TB4 cable and a second laptop. The light on the docking station has remained white.

I’ve sent the plug debug report via the support chat and email.

Thank you for letting us know about this issue and the additional testing performed to try and resolve the issue. Since the dock isn’t working with two systems and you’ve tried another cable to no success it does seem like there is a problem with the dock or its accessories.

> “I’ve sent the plug debug report via the support chat and email.”
Thank you, and it looks like we have responded to your direct email and will be arranging to send you a pretested replacement dock under warranty.

Thank you and best wishes,

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.