TBT3-UDZ occasional connection "lost" causes annoying issue

After enjoying TBT3-UDZ for a while and am generally very happy about it, I also noticed an annoying but quite occasional issue.

It looks like that every about 2 to 12 hours, the dock will disconnect one of USB or display for a very short moment, probably less than 0.1 seconds. I will either see display went blank for a very short moment, or Ethernet gets disconnected, and / or just Windows makes sound notifying device removed and then immediately added.

The issue itself is fine but sometimes because it gets reconnected too fast, system is not handling it properly. Ethernet will sometimes not working with error shown as “same named device already exists” and refuses to work until I disconnect and reconnect manually. USB connected hard drive might not be mountable for similar reason. Display might not get initialized properly that it defaults to a very low resolution. All these issues happens on even more rare occurrences, about once one or two days. And all fixable by just disconnect and reconnect manually.

I have the same issue with two different units of TBT3-UDZ and on two different laptops, one ThinkPad T470 and one T480. They are in different locations so most connected devices are different too. All driver, firmware, and OS are up to date.


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Since this is happening in two locations with two docks and two laptops, it is quite strange. I’d like to get a closer look at the issue by running some diagnostics on one of the systems, I don’t think it matters which one for the moment.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock with your devices attached to it into your computer, then go to this page and follow the instructions there:


Please mention ticket 327443 when emailing us the results. Hopefully I’ll see something being recorded by the system that could indicate why this behavior is occurring and we can proceed from there.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

HI Joshua,

I tried to run the debug tool but it somehow stuck at “COMPRESSING…” forever. I tried it a few times and waited for 10 or more hours but it never finished. The task is not seemingly doing anything as its CPU and disk activities are 0. Please help!

Sorry to hear about that! It might be worth running the tool on the other laptop if you can. Usually the diagnostics doesn’t take more than about 5 minutes to complete.

You can also try running our older version here on the laptop where it got stuck: https://s3.amazonaws.com/plugable/bin/PlugDebug/0.9/Plugdebug-Win32-0.9.1.exe

If that still doesn’t work just let me know and we can try a different approach to these issues.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.