TBT3-UDZ Ethernet is not functional

New dock TBT3-UDZ, connected to a 2019 16" Macbook Pro. 1GB Ethernet is not functional. Same cable connected to a USB-C port via USB3->USB-C dongle works fine. Please help.

Thank you,

Ed Benyukhis

1 Like

I’m also having this issue - plugging in to a MacBook Air M1. I can’t even find where to get the MAC address of the dock; normally docks have a sticker someone with the MAC address, but this one doesn’t. How does one configure the ethernet adapter over Thunderbolt 3 in macOS 11?

Hello @benyukhis and @dnoiseux,

Thank you for contacting Plugable support! Sorry to hear about this issue you’re both having. I’d be more than happy to assist.

For Ethernet issues, we’ve been seeing that macOS may have trouble detecting new dock Ethernet upon first connecting to a system. If you haven’t already done so, fully unplug the dock from all devices, power, and Thunderbolt 3 cable to the host computer. Wait about 30-60 seconds, then reconnect the power cable first, Thunderbolt 3 host cable next, and USB devices last.

In our experience, this has worked, and the Ethernet is detected correctly upon disconnect/reconnect in the future on both Intel and M1 Mac systems.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

All good now with Big sur

1 Like

Hi Joshua,

I’m afraid I’m not having any luck. I’ve tried unplugging the dock from everything, then re-plugging the power, then the TB, then the Ethernet… multiple times and in different locations the last 2 days, and it still is not being detected. At first I was at my office and I don’t have full control over their LAN so I thought I’d bring it home to test, where I have access to the router and can check the DHCP clients… and it’s just not connecting to the LAN. It doesn’t appear in Network Settings (whereas other docks do) and I can’t seem to get anything working.

All other ports I’ve test work fine, it’s just the Ethernet that doesn’t work.


@dnoiseux Thanks for the update, sorry you’re not having any success.

We have a troubleshooting tool that helps us find out what is going on in situations like this. If able, please plug the dock into your computer, then go to this page and follow the instructions there:


You can reference ticket 326370 when emailing the results. This will let me see if the hardware is detected but not being setup properly by the system. It’s possible we’ll have to manually add the Ethernet connection in the system preferences.



Hi again Josh,

I poked around and got it working… I went into network settings, then from the list of available interfaces, clicked the + to add an interface. I added “Ethernet 10/100/1000”, since I had noticed that this interface showed up in System report when I connected the dock, but wasn’t showing up in Network Settings… this added “Ethernet (en6)” to my list of interfaces. Still nothing worked… so then down at the bottom, I clicked the ellipsis icon, then “manage virtual interfaces”. I selected Thunderbolt Bridge, clicked the pencil icon to edit it, and then in the list “interfaces to include in this bridge”, and checked off “Ethernet (en6)”. Then suddenly I was connected! I checked my router and indeed my MacBook was showing up with the MAC address of my Thunderbolt Bridge.

I’m not sure if this is how it’s supposed to work, or if it will prevent future docks from working, but it works for now and I’ll troubleshoot further down the line if I need to.

1 Like

Thanks for the update! Glad that worked out, you did pretty much exactly what I’d have recommended to do after confirming the Ethernet adapter did show up in the system report. The only difference is the settings for the bridge, but I don’t anticipate that will cause any ill effects.

If you need anything else don’t hesitate to let me know.

Thanks and best wishes,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.