TBT3-UDZ - Dual DisplayPort Not Working

MacBook Pro (16-inch, 2019)
Version 11.0.1 (macOS Big Sur)

Asus VS238

I just hooked up a new dock. USB ports and ethernet seem to be working great. The problem is that neither of my monitors are being detected. I also tried testing out the HDMI ports and still had no luck. I’ve tried power cycling the laptop, dock, and monitors in various orders as well. My setup worked using a couple Anker adapters, but I’m really hoping to get the udz working for that convenient single cable plug-in.

Any help is appreciated! I’m about to also ping Apple support and will follow up about that if I find out anything helpful.


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Can you tell me how the monitors are currently being connected? You mentioned trying HDMI, but are you using standard HDMI to HDMI cables, or is it being converted in some way?

For reference, if trying to connect via DisplayPort, if not using a native DisplayPort monitor, you’d need to use active adapters as passive adapters are not supported.

Also, are you connecting the dock to the laptop using the provided Thunderbolt 3 cable? Third party cables may not properly support the dock for full functionality (video, etc).

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

Hey Joshua,

Thanks for the response! My monitors are currently being connected via DisplayPort to HDMI cables (I have been using these cables and monitors together for years). However, I did test this out with HDMI to HDMI cables as well; no dice :frowning: I am using the provided TB3 cable, but have tested with others as well.

From my troubleshooting thus far, I’m inclined to say this is an issue on the Mac end of things. I just tested, and my previous setup sans dock no longer works. I’ve gone through all the standard Mac troubleshooting (powercycling, cable swapping, resetting NVRAM, SMC, etc.) with no improvement. I have yet to hear any further steps from Apple, but a new OS update released today so maybe that will help.

I’ll be sure to update if I get anything helpful from Apple. Feel free to keep tossing other troubleshooting ideas my way though!

Thanks for the update and additional information!

Sorry to hear you’re not able to get things working without the dock anymore either, very strange!

Please do keep us in the loop if you’re able to get any help from Apple here, and I’ll also update if I can think of another solution to this issue. Also, thanks for proactively doing that troubleshooting, you’ve already tried all of the major things I’d have suggested myself at this point.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.