TBT3-UDV No longer supplies power

I have TBT3-UDV dock that I have been using with 15" MacBook Pros for a couple of years now. Recently, it stopped providing power to the host altogether. Data and display connectivity continues to function.

A couple of notes:

  • I realize this dock only provides 60W of power which is not enough to keep a 15" MBP charged under a full load. However, this is usually enough power for my daily usage.
  • I can confirm that the MacBook Pro is plugged into the host TB3 port that provides 60W of power and not the downstream TB3 port.
  • I have two TB3 MBPs. The issue is present with both laptops.

Thanks!

Hello and thank you posting!

I am sorry things are not working as expected with your TBT3-UDV docking station and I would be happy to help.

Thank you as well for the detail you provided and the troubleshooting you have already performed that is all much appreciated.

A quick question for you…can you confirm that you are using only the 0.5 meter 40Gbps Thunderbolt 3 cable we included in the box with the TBT3-UDV to connect it to your laptops? I ask because other cables can sometimes cause problems.

Pending that additional information (and assuming for the moment that you are in fact using the included Thunderbolt 3 cable), based on your description of the behavior our first step is to completely reset the dock and the current laptop in use to help ensure both are in a good state. To do so, please follow these steps:

  1. Disconnect the dock’s Thunderbolt 3 cable from both the back of the dock and the laptop, and disconnect the dock’s power cable so the dock turns off completely.

  2. Shutdown the laptop completely (do not just restart).

  3. Power on the laptop and login.

  4. Reconnect the power cable to the dock, and you should see a solid green light on the front of the unit.

  5. Then reconnect the Thunderbolt 3 cable to both the dock and the laptop, again making sure to connect the Thunderbolt 3 cable to the dock’s 60W charging port (the one with the laptop icon above it). You should then see a solid blue connection light on the front of the dock.

  6. Test the charging behavior again.

If that does not help, our next step is to get some additional information.

If you would, please keep the dock connected to your system as described above (even though it may not be charging as expected ) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket # 295172’ in the email subject line. This will allow us to examine some log files from your system to help determine the next steps.

** Please also include the Amazon Order ID number for the TBT3-UDV purchase in your direct email, it is required to confirm warranty status **

** Please do not post either the PlugDebug file or the Amazon Order ID number in our public forum **

Thank you for giving us the chance to help!

Bob
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.