TBT3-UDC3 ethernet stopped working after Big Sur 11.2.2 update

I know there is a similar thread that was closed…problem persists.

Updated MacBook Pro 13 inch M1 three days ago to 11.2.2 which includes updates for ports/docks. Ethernet will not work once I connect to USB-C. I have tried rebooting the dock as well as network equipment. In the end I must remove the ethernet cable from the dock to use Wifi and access internet.

NOTE: I have confirmed that the Ethernet adapter has an IP address and have released/renewed

Hi Matthew,

Thanks for posting!

Given you’ve already tried a full power-cycle of the dock, our next steps would be to reset the Ethernet config on the Mac side by following these steps:

  1. Disconnect the dock from the system, and please remove the power cable from the dock, so it turns off completely (this is important, so the unit resets)
  2. Go to System Preferences > Network
  3. For each Network device on the left (not including WiFi), select a network device from the list and then click on the (-) button to remove it from the list. (This step will need to be repeated for each network)
  4. Click on the OK button
  5. Reattach the power cable to the dock first. Once the dock is powered on, reconnect the dock to your system and observe the Ethernet behavior

Please let me know if that helps at all.

Thanks for giving us a chance to help!


Worked like a charm thank you so much!! I think the key was removing the former ethernet adapter/device reference.

Great! Agreed that usually removing the previous Ethernet interface is usually sufficient, however sometimes customers will have mutliple Ethernet devices configured from other adapters or docks that have been used :slight_smile:

In any case, I’m glad that worked. I’ll be closing this thread, but if you have any other questions or concerns, please feel free to post a new topic or reach out to us at support@plugable.com.