TBT3-NVME2TB on Mac "please eject disc before disconnecting" messages

My Plugable disc is available on my Mac Pro, running Big Sur 11.5.2
Unfortunately, I keep getting multiple “please eject disc before disconnecting” messages that are filling the notification side of my screen.
I’ve tried a couple of fixes that I found online, e.g., resetting the RAM, but to no avail. I’ve tried wiggling the cable and I’ve tried plugging it into other ports.
My only work-around is to physically disconnect the disc when I’m not writing to it.
Anyone else had this occur and/or have any suggestions?

Hello Terry,

Thank you for contacting Plugable support. We are sorry to hear you are experiencing this issue and would be happy to help assist.

We would like to take a closer look at this issue to better help assist but require some additional information. Instead of posting that information here, could you please contact us directly via email? To do this, please email us at support@plugable.com. In the subject of your direct email, please reference case #354170 which will allow us to match things up and then provide the next steps.

Apologies for the extra steps in the process, and we thank you for giving us the chance to help!

Best regards,

Michael S.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.