TBT3-NVME1TB drive will not mount


I have a:
Acer Swift SF514-51 laptop

I just plugged in my TBT3-NVME1TB drive and I get a message that shows that it is detected but that it needs to be “authenticated”. The drive is shown under the USB section in Device Manager. I read the instructions from Plugable and have tried to download the Thunderbolt 3 Control Center software from Microsoft Store but I get the error code 0x803FB005. Does anyone have a solution for this? Should I just return the drive?


Hello David,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

I believe that error is because you’ve installed the incorrect version of the Thunderbolt 3 utility. I’d remove the version you just installed via the Microsoft store and then try this latest legacy version here:


If this still doesn’t help please let me know and we can proceed from there.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies

http://plugable.com | http://performance.plugable.com/

Hi Joshua,

Thanks for the download. The installation completed successfully, but I still get the same message when I insert the USB-C cable. And I get the same message in Microsoft Store. Is there anything else I should try?


Thanks for trying, sorry it’s still not working.

With the driver provided you shouldn’t need to use the Microsoft App Store version of the Thunderbolt utility, rather, you should now be able to use the legacy utility that should have been automatically installed alongside those drivers.

To better assist with this kind of issue we’ve been working on a page to document Thunderbolt 3 authentication processes. While not yet fully completed, it may serve as a helpful tool in this situation: https://plugable.com/tbt3auth

I’d take a look at the first section titled “Legacy Thunderbolt 3 Authentication (non DCH Thunderbolt 3 drivers & Thunderbolt Utility)”. We also have an accompanying video.

It’s possible that your system may also have a mix of drivers which can cause issues:

So far, we’ve had the best experience with the Legacy drivers and app which is why we’re recommending the legacy solution.


Thanks for the links. I did “sc delete nhi”, and verified that this component was not installed. Then installed the legacy drivers and control software that you linked to. Then I rebooted my laptop.

When I plug in my thunderbolt 3 drive (plugable.com) I get the message “Thunderbolt device functionality might be limited”. Then I have a look in the device manager and I see a device called TBT3-NVME under “usb serial bus devices”. I have also included a screenshot of the properties view of that device. There is a message that the drive cannot be “migrated”, which I take to mean that the drive cannot be recognized.

Do you have any additional advice? I’m afraid that I need to return this device since I cannot get drivers the work.


I just found out through the acer community forum that thunderbolt 3 is not supported by my Acer SF514-51 laptop. Thanks anyway for your help. I leave having had a good customer support experience even though I do need to return my SSD.


1 Like

Thanks for the update! Sorry to hear the lack of support on this model has been confirmed - that certainly explains why you weren’t able to get it going, though it’s interesting that Windows knew you had a Thunderbolt 3 device attached even though the system is not TBT3 capable, and that it can be seen in the Device Manager under USB devices.

If you need any assistance with the return please let me know.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.