TBT3-HDMI2X-83 Macbook Pro, Asus VS248H-P dual monitors stopped working after changing resolution

Since late 2018, I have been using my TBT3-HDMI2X-83 to connect two Asus VS248H-P monitors with my MacBook Pro (15-inch, 2017) with an Quadcore i7 Intel chip (when connected, I close the laptop and have dual monitors). I’ve never had any issues, but recently my computer has been running slower and hotter when working on dual monitors, and I read that lowering the resolution from 1080p could help reduce the load on the computer. So yesterday, I began trying out different resolutions to see if I actually wanted to do this, and then when I clicked on one of the resolution options (I think it was 1344x1008 but I don’t recall exactly), the screens went black as they do when you switch resolutions, but then didn’t come back.

I manually shutdown my MacBook Pro and then powered it back up, but if the TBT3-HDMI2X-83 was connected with both monitors connected via HDMI, the laptop wouldn’t finish loading up after I logged into my profile (it would restart and say the laptop had restarted due a problem). When disconnected, the laptop worked fine, and when I tried connecting each Asus individually via each monitor’s HDMI cable directly into the laptop, things worked fine. But when I had the laptop on and plugged in the TBT3-HDMI2X-83 with both monitors connected via HDMI, one of the Asus screens would light up momentarily to say “HDMI connected” but then neither screen ever came on with the desktop image. Meanwhile, the laptop screen (which I had open, not closed) would essentially be frozen up as I couldn’t get the mouse to show up.

After I first ran into this problem and had disconnected my computer and restarted it, my ColorSync Utility appeared and said there were a handful of ICC profiles that needed repair. All were in Adobe files, but I had never seen this problem before and wondered if it had anything to do with the larger problem I was having. I was able to repair them, but my overall problem persists.

All in all, it seems like the computer and TBT3-HDMI2X-83 are interfacing in some way because one monitor tries to connect, but it never completes the process. I would appreciate any advice on how to proceed!

Thank you,

Hi Geoff,

Thank you for posting! I am sorry things are not working as expected while using your Plugable TBT3-HDMI2X-83 adapter and I would be happy to help.

Thank you as well for the thorough detail you have provided and for the troubleshooting that you have already performed that is all much appreciated.

I am afraid that I cannot be sure of the cause of the behavior based on the description alone.

However, based on your description I suspect that when you attempted to lower the resolution of your Asus displays you picked a resolution option that the Asus displays did not actually support.

In other words, your Mac is attempting to run the displays at the lower resolution but since the displays do not actually support that lower resolution, they are not working properly.

In our experience helping others in similar cases, a good first step is to reset the display settings within macOS to their defaults in an effort to undo the changes you made previously. This can be accomplished by following these steps:

  1. If not already, please disconnect the TBT3-HDMI2X-83 adapter from your Mac.

  2. If not already, please disconnect any external displays that are directly connected to your Mac.

  3. Download the ‘Reset macOS display persistence’ script from DisplayLink → https://synaptics.com/products/displaylink-graphics/downloads/macOS-display-persistence-reset to your ‘Downloads’ folder.

*** For your refence, the TBT3-HDMI2X-83 adapter does NOT have DisplayLink technology inside of it. We are simply using a utility provided by DisplayLink to reset the display settings within macOS ***

  1. Unzip the file by double-clicking on the download.

  2. Open the ‘Terminal’ application on your Mac. You can do so by opening the /Applications/Utilities folder within the Finder, and then double-clicking on ‘Terminal’.

  3. Once within the Terminal, run the following commands one at a time (* capitalization and spacing matters *) by pressing the Return key on the keyboard after each individual line. You can also copy and paste the commands if that makes it easier to do so:

cd ~/Downloads
chmod +x ResetDisplayPrefs.command
sudo ./ResetDisplayPrefs.command

  1. The script will prompt you for your Administrator password. Please type the password and press ‘Return’. ** You will not see the password as you type it nor will the cursor move, this is expected **

  2. The script will then prompt you to proceed. Press the ‘Y’ key on your keyboard to continue.

  3. The script will complete, and then prompt you to reboot your system. Close the Terminal application, and please reboot.

** I have attached a screenshot to the bottom of this post that demonstrates the entire process within the Terminal for your reference **

  1. Once the process is complete, please try connecting the TBT3-HDMI2X-83 adapter to your Mac (with both Asus displays connected) again.

Apologies again for the frustration, and thank you for giving us the chance to help!

Plugable Technologies

Hi Bob,

I followed your instructions and they appear to have worked! My dual monitors are back online. Thank you for your help with this!


Hi Geoff,

I am jumping in for Bob as he is out. Thank you for the update and that is great to hear that the steps Bob provided helped!

If run into any other issues or have any additional questions regarding our products we’d be happy to assist further.

Thank you,

Plugable Technologies